Using latest 18.06.1 firmware, it can't support for raspberry pi3 b+

I use the latest openwrt firmware, but it does not support raspberry pi3 b+. Please help me, thank you.

Can you better explain why you believe 18.06.1 doesn't support the Pi 3 b+?

I download image file the address.
The following:

I used openwrt-18.06.1-brcm2708-bcm2710-rpi-3-ext4-sysupgrade.img firmware and burnt image file to SD card.
It run on raspberrry pi3 b+ and it is abnormal, but on raspberry pi3 b is normal.

In what way is it abnormal? What happens?

Ethernet is abnormal and HDMI interface display.
Rpi3 b+ showing:

But Raspberry pi 3 B is normal, HDMI interface have output datas.

Did you replace start.elf and bootcode.bin from the raspberry pi os image

OK. I try it, thank you.

Replacing those files results in the console being available when connected to a monitor/TV. However, I do not see any 'Wireless' under Network. Is something missing?
Or maybe snapshot would be an option for the time being?

You don't need to replace bootcode.bin. Just replacing start.elf (from the latest Raspbian OS) is fine. Still, WiFi is not detected on Pi 3 B+.

1 Like

Just wondering, now, December 2018, why the problem with non-functional OpenWRT image on RaspPi3B+ hasn't been solved. I just got some RaspPi3B+ as replacement devices for some older RaspPi3B (NO plus!) and additional ones two days ago. The official OpenWRT image still doesn't boot with the symptomes desrcibed herein, the SNAPSHOTs do have serious problems bringing up the WiFi as an AP.

I've already added WIP and WiFi 2.4Ghz as unsupported feature under RPi 3 B+ ToH

Try adding this to config wifi-device 'radio0' in /etc/config/wireless: option short_gi_40 '0' This allows me to run a 2.4GHz AP.