Using imagebuilder - rpi4 related

Hello everyone, so I'm having a go with openwrt on a Rpi4 and from what I've seen you can't use systemupgrade to update, it's a case of reinstalling openwrt each time on the SD card.... I tested by doing a basic config, then updating via sysupgrade and can confirm despite having the keep settings box checked it wiped the lot.

So what do I need to do to allow me to not have to fully set up the system each time from scratch?

Will generating a backup, flashing the new image onto SD card, then restoring the backup work??

Or can I set the system up, generate a backup and include it in the openwrt imagebuilder so the newly made image that's put on the micro SD is ready to use.

Where did you see that?

1 Like

It was in one of the rpi topics I've been reading, I think it had something to do with removing some drivers for adaptors or something??

If I compile my own from imagebuilder they should be in the sysupgrade image anyway?? So would it work?

Also from the imagebuilder can I make the system use the full SD card as storage.

Hi, @Thebroughfamily,

The only situation where sysupgrade seems to fail is when you extended your root partition, otherwise, it just works as expected and does not wipe you configuration.

I explained in this post how to keep configuration between upgrades if you use Image Builder, even when you have to do a full install wiping your card: Raspberry Pi 4 released

And, the problem with Image Builder and setting the root image size it's that you will need that free space in your drive, just in case you are using a VM take it in account, as I ran out of space in my Linux VM because of this.

Hope this clarifies, mate.

Hi amteza, I tried to follow your steps but couldn't make sense of it, I'm not that good with it... Until yesterday I hadn't even used imagebuilder so it's a big learning curve. I had hoped I could unzip the backup file and put it's contents somewhere so it got built into the firmware automatically.

But on another note, I see you say you can't use your UE300 USB to Ethernet adaptor until fixes appear, I thought this one was recommended to use... So what one would you suggest I order as I was gonna grab one of those tomorrow.

Hi, @Thebroughfamily,

My bad, I think I did a poor job explaining myself. The USB3-to-Ethernet UE300 I bought works... but in another thread it was found that rtl8152 drivers in Linux fail due to autosuspend issues: Update kmod-usb-net-rtl8152 Driver to avoid USB 3.0 to Gigabit LAN issues?

Because, sadly "down unda", we do not have proper broadband bandwidth at our disposal —how I miss my cheap symmetric 600/600 Mbps from Spain— it does not matter to me that asix-ax88179 drivers are not so efficient, as long as they are stable and without the rtl8152 issues, which seems to be the case. This is the only reason I am waiting on an upgraded driver for rtl8152 in Linux/OpenWrt. And, this is the cheap adapter with ax88179 chipset I bought:

In regard to creating an image with Image Builder, my steps are only in case you have already OpenWrt installed in your device, please, be aware of it as otherwise, makes no sense. What part do you find tricky? I know I tend to be oblivious to detail as I think most people will manage, apologies again if it is not the case, mate.

Kind regards.

So at the minute I'm best to avoid the UE300 until the drivers are updated in the Linux kernel, and stick with something ax88179 based as they work for now, as this will be my home router it needs to be reliable as possible.

I've built several firmwares for my pi now, adding things I'd forgotten, removing things I didnt need. With everything being so modular it's easy, but also difficult as it's hard to know what you do need.

So, because of your post I am right now building my distro/firmware with latest patches from Realtek, I had it pending. Let see if it finish, I will keep you posted. I have the .patch file ready if you feel comfortable applying it yourself.

@Thebroughfamily, tested, it's working:

[1049165.869005] usb 2-1: new SuperSpeed Gen 1 USB device number 4 using xhci_hcd
[1049165.894069] usb 2-1: New USB device found, idVendor=2357, idProduct=0601, bcdDevice=30.00
[1049165.902451] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=6
[1049165.909814] usb 2-1: Product: USB 10/100/1000 LAN
[1049165.914708] usb 2-1: Manufacturer: TP-LINK
[1049165.918992] usb 2-1: SerialNumber: 000001000000
[1049166.057359] usb 2-1: reset SuperSpeed Gen 1 USB device number 4 using xhci_hcd
[1049166.154609] r8152 2-1:1.0 eth2: v2.13.0 (2020/04/20)
[1049166.159837] r8152 2-1:1.0 eth2: This product is covered by one or more of the following patents:
[1049166.159837] 		US6,570,884, US6,115,776, and US6,327,625.
[1049166.184249] br-lan: port 2(eth2) entered blocking state
[1049166.189670] br-lan: port 2(eth2) entered disabled state
[1049166.195232] device eth2 entered promiscuous mode
[1049166.200150] br-lan: port 2(eth2) entered blocking state
[1049166.205560] br-lan: port 2(eth2) entered forwarding state
[1049166.211372] br-lan: port 2(eth2) entered disabled state

Let me know if you want the .path file or a .ipk file to try it. If you want the second, please, I will need your .config file and your device's /etc/openwrt_version file or its content.

I don't have a .config file, I'm still trying out various set ups.

But I'll happily take a copy of the patch if you can give me a hand on how to use it...

I've been using a UE300 in my RPi4 for months with no issues.

1 Like

Okay, @Ark's might be a different brand/model as not all are equally built, IDK. In any case I think it's time to update the drivers and see if they solve at least @Ark's issues.