Using https to access the router is rejected via web

version : lede 17.01.1 & openwrt 15.05.1

Using https to access the router is rejected via web.

/etc/config/uhttpd (lede) :

config uhttpd 'main'
	list listen_http ''
	list listen_http '[::]:80'
	list listen_https ''
	list listen_https '[::]:443'
	option redirect_https '1'
	option home '/www'
	option rfc1918_filter '1'
	option max_requests '3'
	option max_connections '100'
	option cert '/etc/uhttpd.crt'
	option key '/etc/uhttpd.key'
	option cgi_prefix '/cgi-bin'
	option script_timeout '60'
	option network_timeout '30'
	option http_keepalive '20'
	option tcp_keepalive '1'
	option ubus_prefix '/ubus'

config cert 'defaults'
	option days '730'
	option bits '2048'
	option country 'ZZ'
	option state 'Somewhere'
	option location 'Unknown'
	option commonname 'LEDE'

How can I fix it?

It uses self-signed randomly generated cert. Browser will reject it unless cert manually added to trusted root.
In LAN there's no reason to use https. Disable redirect


Not chrome blocked

Are you trying to access the router from wan internet? Have you opened the port in firewall?

Wan ip is c class subnet.
How do I modify the firewall?

I already know through google

  1. install luci-ssl
  2. uhttpd restart