Using Build System to compile custom firmware image - old package vesrions and unable to remove some packages

I've compiled a firmware image (based on official 19.07.3 release) for TL-WDR4300 v1 using the Build System.
I've expected that I'll get the latest packages versions (Adblock for example and all others that opkg shows have updates as of today) with the newly compiled firmware.
Instead I've received older versions even from those included in the official generic firmware image (19.07.3) on the OpenWRT site.
Is this supposed to be this way. Is it the same if I use Image Builder?

Additionally I've tried to compile a firmware image for WDS DumbAP for another router.
I wanted to remove the unnecessary packages (IPv6, dnsmasq DHCP and DNS, PPPoE, iptables, firewall, etc) using menuconfig.
I've successfully removed almost all of them but I'm unable to remove Firewall and Luci-App-Firewall marked with -*- because of the package dependencies. I cannot deselect them from the config menu and I don't see a way to remove the dependencies from/to other packages.
Is there a way to remove the firewall.

Using Image Builder and Packages="-firewall -luci-app-firewall" seems to remove them but I don't know if the dependencies are removed as well.

Obviously I was doing something wrong.
Today tried to build the firmware image from snapshot repository. Using the Image Builder it included packages that I didn't choose in the final image.
Using the Build System I got this message - WARNING: Makefile 'package/system/procd/Makefile' has a dependency on 'libselinux', which does not exist. I've checked the packages and there is libselinux1 listed.
The image was compiled though and factory and sysupgrade.bin files were created.

The "19.07.3 release" is a fixed point in the 19.07 branch history, not the newest stuff. If you checkout 19.07.3, you will get just the packages of that time. Instead, you might have checked out the HEAD of the 19.07 branch to get the packages later updated in 19.07. (There are also snapshots for 19.07 HEAD, although semi-hidden at )

In you second message you have apparently changes to master, as the current procd mis-dependency is just there. In general, master has all new stuff, while the old 19.07 branch gets mostly security fixes and some backports from master.

my old graph explaining the branches:

1 Like