Using Alfa Tube-UAC2 connected to a Nighthawk X4S (R7800)

For the past couple of weeks I have been trying to get an Alfa Tube UAC2 to work as a Wireless WAN connection on a Netgear Nighthawk R4S running OpenWrt 22.03.5 r20134.

The Alfa outdoor WiFi stick is using the Mediatek 7610U chipset for which I installed the kmod-mt76x0u wireless driver.

The problem:
I am able to scan for wireless networks and connect to one without any issues. But as soon as I try to put some load on the uplink it just stops working. The only thing I can do to reestablish the connection is rebooting the Netgear.

I tried upgrading to the OpenWRT v23.05.0-rc2. This didnĀ“t improve the situation but gave me less logging information.

DMESG shows me this, it looks to me that the problem has something to do with the USB3 interface.
By the way, I also tried an USB Y-cable to power the stick from the 2 USB ports on the R7800.

DMSEG logging:

[   51.939142] wlan2: associated
[   51.941605] wlan2: Limiting TX power to 17 (20 - 3) dBm as advertised by xxxxxxxxxxxx
[   53.104105] IPv6: ADDRCONF(NETDEV_CHANGE): wlan2: link becomes ready
[  922.070897] xhci-hcd xhci-hcd.1.auto: xHCI host not responding to stop endpoint command.
[  922.070949] xhci-hcd xhci-hcd.1.auto: USBSTS: 0x00000000
[  922.110067] xhci-hcd xhci-hcd.1.auto: Host halt failed, -110
[  922.110100] xhci-hcd xhci-hcd.1.auto: xHCI host controller not responding, assume dead
[  922.115010] xhci-hcd xhci-hcd.1.auto: HC died; cleaning up
[  922.123745] usb 3-1: USB disconnect, device number 2
[  922.128552] wlan2: deauthenticating from xxxxxxxxxxxxxx by local choice (Reason: 3=DEAUTH_LEAVING)
[  922.134061] mt76x0u 3-1:1.0: MAC error detected
[  922.364177] mt76x0u 3-1:1.0: MAC stop failed
[  922.595626] mt76x0u 3-1:1.0: MAC error detected
[  922.813580] mt76x0u 3-1:1.0: MAC stop failed
[  923.022613] mt76x0u 3-1:1.0: timed out waiting for pending tx