USG no DHCP and internet access on LAN

Hi guys

Been running OpenWRT Snapshots on my USG 3P. Has all been working fine. However, recently I am not getting an IP address+internet from the LAN ports. The USG itself has internet access and I have console access. What troubleshooting steps can i do? Is there a log i can export that can help with troubleshooting?

if you can access the USG via IP, from your lan, without manually assigning an IP on the client, check your DNS settings.

Can't access via IP, can only access via console. I can ping out from it (to Google). Almost like the lan+dhcp config is gone. The ports do light up

does logread -f detect a cable disconnect/connect on the lan port, if you do one ?

Not home with the device atm, but I do recall something popping up in the CLI when I plug in the cable. Will check again when home

I noticed your device have 3 ports, try moving the lan side cable to the other port, if unoccupied.

Tried that already, same result. WAN and console function as they should