Users needed to test Wi-Fi stability on Linksys WRT3200ACM & WRT32X on OpenWrt 21.02

The other solution is to buy a cheap WiFi Access point and let it handle the WiFi. Apart from WiFi the WRT320 is still a fantastic piece of kit.
Linksys behaviour has been truly scandalous however


Apparently the mwlwifi driver does not have an implementation for low_ack reporting. Therefore, the option disassoc_low_ack '0' setting that many of us have used has no affect on mwlwifi.

Source (BrainSlayer): Poor performance and poor stability wrt1900acs v2 · Issue #391 · kaloz/mwlwifi (

short preamble has only effect for legacy (g/b) networks. disassoc in low ack may be a positive effects for kickouts. because this may be related to data the driver reports (or wrong reports to the network stack). so disabling this makes absolutelly sense

edit: the mwlwifi driver does not implement the low_ack reporting mechanism. so this setting should not have any effect

To be honest, I haven't had a single problem as far as I remember on my wrt1900acs with openwrt 19.x and versions before, I also made a lot of custom changes so upgrade to 21.x was painful.
It looks like after removing wpad-basic-wolfssl and installing wpad-basic and removing wifi from all of my apple devices and adding it back worked just fine and I see no issues so far, it's been a day, but at the same time I haven't had these ~30m dropouts like WildByDesign. One time I lost connection on all apple devices, not sure how that happened, but wifi password wasn't even in keychain access, so it was apple related.

@adworacz Have you had any luck with compiling that 5.4 kernel with mac80211 5.7 backport?

Another test would be checking 50f456b46cbae27ed13badfe7b2976cd01b67a57 with kernel 5.4 manually selected and mac80211 downgraded to the last known-good "with mac80211 5.7.5-1 update" - with a little luck that compiles (and works).

If you or anyone is able to compile that successfully, I am happy to test it.

I was just thinking about this recently. If this does compile successfully and runs extremely well, we could potentially create some sort of community build of this for mwlwifi users as sort of a last hurrah for these WRT series of devices.

Potentially, that could include adding future kernel 5.4 bumps as I believe there was one just a few days ago. But also maybe certain package updates such as dnsmasq for security reasons.

This ended up in failure in the end as well. Any and all of my potential and theoretical workarounds for the wireless cutouts on 21.02.x builds have all failed. I have spent months fighting this issue and generally put in about 2-3 hours per day over these past months for testing potential workarounds and such.

Unfortunately, I have zero workarounds that have any success for these constant wireless cutouts between mwlwifi and 21.02.x builds. I have no more ideas left at the moment.

Sooooooo it's funny you should ask, @WildByDesign

I literally JUST created a working build based on the 21.02 branch + mac80211 5.7 last night. I was going to test it a bit longer before I announced anything, but since you asked...

There's one bug that I think I found, but it has to do with Luci not letting me login on first boot. SSH access worked just fine though, and I set the root password there, after which Luci worked just fine. Might have been a browser cache issue, so I want to repeat the test before I say for sure.

So far, my iPhone hasn't disconnected once.

I need to make some minor tweaks to my build process and then I'll post some updated builds.

I also have instructions for how to recreate the build process for anyone who wants to make their own builds.

I believe this opens the door for us to create builds against 21.02 and possibly master with a forced kernel downgrade. I haven't tested to see if I can complete a master build just yet.


I'm pretty sure that this is a known bug that has to do with the cookie that is set in the browser. I hit this bug with every 21.02.x RC and builds with logging into LuCI. jow had posted a workaround. Link: Stops at login page [WRT3200ACM] · Issue #5104 · openwrt/luci (

I am very excited that you have had success with this build and that it's running well so far. Cheers!

Ahhh excellent, I was hoping that was the case. Thanks for the link!

I'll skip any more tests then and create some new test builds tonight to vet my own instructions. Will post them here when I'm done.

1 Like


Here you go, r16335:

This is the combination of openwrt-21.02 commit 4b0f87729c2e3c0571663e6f882fe726fef99f74, while using the old mac80211 5.7.5 from commit d1100c76b33ff68c6db0f5fa31a26532bdbb15c4.

With this we basically have all of the benefits of OpenWrt 21.02.1, with working wireless on the WRT3200ACM and WRT32X.

If that build tests well, I'll create a proper guide for recreating the build for anyone to use. It's essentially using all of the files/scripts/patches in this folder:


Guys, I have to say I am amazed by the work done here. I initially followed this thread for a similar issue on a WRT1900ACS that was solved with a different solution. But I kept following it as it reads like a good thriller ! And seems like there is a happy ending. Well done all !!

1 Like

hello all,

you can also solve stability wifi driver issues for wrt1900acs v2?

I sort of doubt the wifi stability issue is anything to do with the driver - since my 3 WRT32X's have been rock solid for years with all OpenWRT versions I've thrown at it

Maybe I'm lucky ... 3 times

Well I am a bit late to the party as I only just got around to upgrading my 3200ACM recently. Is there anyone who can give me a jest of what you guys have discovered so far in dealing with these issues?

I noticed that there were quite a few issues with wireless as my sisters iPhone was causing my entire network to become unresponsive until rebooting the router. I seemed to have fixed the issue by completely disabling ipv6 on my interface.

The only issue that I have left right now though is that for some reason LuCi seems to become unresponsive, and is throwing "XHR request timed out" error messages. SSH works however, so I am able to configure everything through that in the meantime.

Any help would be much appreciated!

While testing on WRT32X, when I configure WPA3 it locks up the router when I connect to it.

Edit: Huge Brainfart. I knew better... Anyway testing.. will report back soon.

1 Like

Don't, WPA3 is not supported on mwlwifi.

1 Like

Hey all, it's been almost three days and I haven't had a single problem with openwrt 21.02.1 on my Linksys WRT1900ACS. I tested at least my 4 primary devices intensively through these days - work laptop running windows, personal macbook pro and iphone + android tablet - not a single disconnect or device being stuck on wifi without network access. To summarize what I've done:

  1. removed wpad-basic-wolfssl and installed wpad-basic, forced wpa2 auth
  2. disabled ipv6 (that I do every time I install/upgrade new version as it's a mess)
  3. turned on Disassociate On Low Acknowledgement - not sure if that even works or if that's turned on by default.

Good luck everybody!

1 Like

And your WRT1900ACS uses a different wifi chip and a different closed-source firmware for that, than WRT3200ACM and WRT32X.

Have you tried this?

1 Like

If you don’t mind, could you please describe your steps for how you disabled ipv6 in your setup? Or link to a post with the steps you followed. Thank you.

@adworacz Excellent job! I will try this build out tonight and I will throw everything at it, including the kitchen sink.

I will give this build a thorough test now for a solid 4-5 days.

I get it, this thread is mean for 3200acm/32x, however multiple people commented with issues on 1900 devices and as long as it's not confirmed that only 3200acm/32x are affected, it might be a common problem.

1 Like

One thing that I know for a fact and from previous experience, mwlwifi does not get along well with Intel wireless chipsets. As a matter of fact, the combination was always a disaster. Particularly with Intel wireless chipsets that were a couple of years older.

Sometimes it’s hard to know what wifi chipset is in our mobile devices. Especially iPhones because the same model can be released with 2 or 3 different wifi chipsets depending on supply and manufacturing.

I wonder if Intel wireless chipsets are the majority of devices involved in this issue. I don’t know, but I am curious.

1 Like