Users needed to test Wi-Fi stability on Linksys WRT3200ACM & WRT32X on OpenWrt 21.02

Maybe, for refence here is the original bug report thread from a few years ago where it started:
[https://github.com/kaloz/mwlwifi/issues/313]

Sadly mwlwifi project has been abandoned for years. U6-Lite wifi 6 ap took care of that.

Sadly mwlwifi project has been abandoned for years. U6-Lite wifi 6 ap took care of that.

Same here, this is still my main router and can't find anything with such good hardware, but the WIFI runs on U6-Lite now

1 Like

Upgraded to 22.03.0 yesterday, and my WRT32X is now having trouble on 5GHz. It was running flawlessly on 21.02.3. I did a clean upgrade (didn't preserve any settings), and reconfigured by hand to reproduce the same settings I had before: 5GHz only on radio0, channels 36/149, WPA2-PSK only. No other tweaks.

It seemed to work initially, but when I woke up today all my WiFi devices were disconnected and wouldn't reconnect. Tried restarting radio0 several times and changing some settings, no help.

Just restarted the router entirely and it's fine again, at least for now.

1 Like

Having the same problem:

5Ghz was unstable on my Linksys WRT1900ACS with OpenWrt 21.02 on channel 36.

Changing the channel to anything higher than channel 36 rendered 5Ghz unusable.

I had hopes, that upgrading to OpenWrt 22.03.0 would solve this, but it didn't.

My Questions:
What are actually possible ways to fix this ?
Are there other drivers that could be used ?

Thanks for info and help on this.

sklerotraficon

Unfortunately the no one have the source for the WIIF firmware/driver, last commit to the WIFI driver was 3 years ago: https://github.com/kaloz/mwlwifi

some background info, wont solve your problem, but gives some context:

All that said, having access to the unknown code underlying the binary driver shouldn't be strictly necessary, given we know that past versions of OpenWRT did not cause this problem. Someone with knowledge of OpenWRT code and one of these routers on hand should be able to, given time, first, reproduce the issue, and then at least narrow down which specific code change was where the 5GHz problem started.
This sort of bisecting is exactly what @adworacz did to find the source of the other problem that was discussed in this thread last year.

1 Like

Following up on my experience with 22.03.0 so far -- after almost a week, the 5GHz issues haven't returned on my WRT32X. (I previously reported that all my devices got disconnected and couldn't get back on until I did a full reboot.)

Not sure what changed since that first day I initially installed & configured 22.03.0. I'm using the same 5GHz channels, WPA2-PSK, and the 2.4GHz radio is still disabled just like I had it with 21.02.3. No mods or tweaks to drivers or other settings. I did do a channel scan and a couple of reboots to configure SQM and the firewall, but those shouldn't have affected WiFi.

Again, other than that first day, my 5GHz network has been stable so far.

Given the open issue history of that device family since v19 (the non-fixable and probably fixable), I guess there are less and less someones left who are willing to invest time to do that. Could be that most developers and bisectors have turned to different devices.

1 Like

It’s sad that the binary file has an explicit license that reverse engineering it is not allowed. So any attempts at providing an open source driver derived from the binary would probably merit a lawsuit, but no one at Linksys wants to give up the code.

I wonder if there are ways to reverse from the actual hardware itself, as that should be allowed last I checked. But that task seems to be almost impossible..

I am seeing some discussion and commits suggesting that WRT3200ACM/WRT32X and others may not be supported on 22.03.x releases any further due to that mvebu network switch bug where it’s acting as a hub.

It seems that it will be supported once again once stable builds with kernel 5.15 is released.

Does anyone know if we should go back to a previous release?

Or would it be a good time for the community to come together and create builds based on 5.15 trunk?

snapshots work presumably, plus there are community builds to be had.

1 Like

I may end up switching over to snapshots because I prefer a more vanilla/default experience and make my own changes from there.

Some people above had issues, others didn't. They'd have to follow-up with us to say if it was resolved? Are you talking about the issues people described in this thread in the last six months, or is this "mvebu network switch bug where it's acting as a hub" something newly reproduced? I did just notice that 22.03.3 wasn't built for the Linksys WRT devices.

Different, see thread

Community builds? Where can I find these?

this, there are images off the link on my avatar or github, not sure if hnyman still offers one.

1 Like

Master snapshot is running great on my WRT32X with kernel 5.15 for over 2 weeks. The switch and leds are fixed from my testing. I wouldn't go back to 22.03 or see any need for a new community build, just run Master. See my post here:

[Divested-WRT: No-nonsense hardened builds for Linksys WRT series - #942 by phinn]

Here are the packages I install via ssh right after a clean master snapshot install works great for me (lot of storage stuff since I run a 2TB SSD with Samba network shares for Kodi etc):

opkg update && opkg install luci luci-ssl irqbalance luci-app-advanced-reboot luci-app-sqm luci-app-simple-adblock luci-app-upnp luci-app-samba4 kmod-usb3 kmod-ata-marvell-sata kmod-usb-storage kmod-usb-storage-uas block-mount usbutils mount-utils luci-app-hd-idle kmod-fs-exfat nano nmon htop iperf3

1 Like

Thanks. Do the builds include Luci or must it be installed after flashing?

I assume included in the one I linked, mine do, but check the manifest of each to assess suitability regarding other packages, master snapshots do not.

2 Likes