Users needed to test Wi-Fi stability on Linksys WRT3200ACM & WRT32X on OpenWrt 21.02

I might try that in a bit on my second partition. I was in a bit of a rush to get wifi stable again when I tried a few different builds, pretty sure I tried a snapshot a few days old now as well as 21.* and 19.* older versions. I was not all that methodical about it and discovered this thread late into testing different versions. When I try the latest I will make sure to pay more attention to versions in-case I encounter encounter anything.

I believe that's a master snapshot, not a 21.02 snapshot, but it still has the fix.

I am having a wifi problem with an iPhone (of course, Apple again) on my WRT3200ACM that has been happening since this fix has been implemented but did not happen with Davidc502's old build.

iPhone has been disconnecting from 5GHz band occasionally and when it does, it can no longer visibly see the 5GHz network. The 5GHz network is visible to other devices on the network and still functional for those other devices during this time.

After several minutes, it can see the 5GHz band again and when you try to connect, the iPhone says that the password is incorrect. There is nothing wrong with the password but the iPhone seems to think so. The only way to solve this is to reboot the router.

Unfortunately, there is nothing in the system log when this happens. The only thing that I get is the usual disassociated due to inactivity an hour later.

The reason why it is an hour later is because I had tried setting option max_inactivity '3600' to fix the problem initially. But clearly modifying options disassoc_low_ack '0', option max_inactivity '3600' and option wpa_group_rekey '86400' does nothing to help mwlwifi devices.

It seems to happen after only a few minutes of inactivity. The screen of the iPhone may have been turned off for 3-4 minutes and when you turn the screen back on, 5GHz network has disappeared.

This issue only seems to happen once per day or every other day.

I've jumped to master to test this out and things are looking fine for the mac80211 issue. However, I've also seen another issue with a single Android Pixel 4.

The device was connected fine to the 5 ghz network for about 24 hours when it dropped off and refused to reconnect (even after some reboots of the phone and router). The WiFi network appears to be functional: other devices are connecting as normal, even after the Android glitched out.

I think this is the syslog from when the Android fell off the network. Unfortunately I had random MACs turned on so I am not really sure what device it is but my confidence is high that this is it. For future testing I've disabled random MACs on the phone so I can trace this better in the future.

Wed Dec  1 22:52:41 2021 daemon.info hostapd: wlan1: STA 76:fa:85:62:d0:1d IEEE 802.11: associated (aid 2)
Wed Dec  1 22:52:42 2021 daemon.notice hostapd: wlan1: AP-STA-POSSIBLE-PSK-MISMATCH 76:fa:85:62:d0:1d
Wed Dec  1 22:52:43 2021 daemon.notice hostapd: wlan1: AP-STA-POSSIBLE-PSK-MISMATCH 76:fa:85:62:d0:1d
Wed Dec  1 22:52:44 2021 daemon.notice hostapd: wlan1: AP-STA-POSSIBLE-PSK-MISMATCH 76:fa:85:62:d0:1d
Wed Dec  1 22:52:47 2021 kern.debug kernel: [73766.563449] ieee80211 phy1: staid 2 deleted
Wed Dec  1 22:52:48 2021 daemon.info hostapd: wlan1: STA 76:fa:85:62:d0:1d IEEE 802.11: authenticated
Wed Dec  1 22:52:50 2021 daemon.info hostapd: wlan1: STA 76:fa:85:62:d0:1d IEEE 802.11: deauthenticated due to local deauth request

Interesting, I am seeing lots of AP-STA-POSSIBLE-PSK-MISMATCH also. Although I am getting that after that failure on 5GHz, but not until the iPhone tries to connect to the 2.4GHz band.

This setting, salvaged from over here, appears to let the devices that weren't connecting work again.

uci set wireless.@wifi-iface[0].iw_qos_map_set="none"
2 Likes

My feedback:
After 2 days running (OpenWrt SNAPSHOT, r18244-101300b842 ) on my Linksys WRT1200ac - issue has gone, 5GHz WiFi is stable enough, even with configured WPA3/WPA3 mixed and 802.11w optional.
Big thx to everyone for fixing it!

I am going to additionally confirm that with a 21.02 snapshot r16392-36848e2c29 specifically, things are back in normal worker order. Just a data-point, thanks again to all.

Do you want to do some more bisecting? This one sounds a lot slower than last time, but that should not be a deterrent.
What version are you running?

Running the 11/30/21 master snapshot which includes these mac80211 fixes and can confirm 5GHz is running great on my WRT32X. Not a single issue in 3 days. I see there have been a few more mac80211 fixes in the commits now and look forward to testing those next time I update as well. Thank you so much to those that put in the time for these fixes.

As an aside, I generally disable wifi on the router outside of testing and use the $99 Ubiquiti U6-Lite-US. Although it takes up one of the gigabit switch ports it's significantly faster and provides all the new goodies like WiFi 6, OFDMA, TWT, MU-MIMO, Mesh, single login for all bands with bandstearing, etc.

The mvebu target and specifically the WRT32X / WRT3200ACM is an outstanding fast performing router for everything else, running SQM at 500 Mb/s, Adblock, USB 3.0 NAS w/Samba4 at 120 MB/s, etc.

Below are my packages installed for those curious:

Summary

opkg update && opkg install luci irqbalance luci-app-advanced-reboot luci-app-sqm luci-app-adblock luci-app-upnp luci-app-wireguard luci-app-samba4 kmod-usb3 kmod-ata-marvell-sata kmod-usb-storage kmod-usb-storage-uas block-mount usbutils mount-utils luci-app-hd-idle kmod-fs-exfat iperf3 nano

Hmm...has anyone managed to get radio2 working with this change/newist builds? If I flip back (I think to 5.10.74) radio2 works, but I can't seem to get it to start up under any config anymore.

root@OpenWrt:/etc/modules.d# hostapd  /var/run/hostapd-phy2.conf
nl80211: kernel reports: Registration to specific type not supported
Failed to initialize QoS Map
Interface initialization failed
wlan2: interface state UNINITIALIZED->DISABLED
wlan2: AP-DISABLED
wlan2: Unable to setup interface.
wlan2: interface state DISABLED->DISABLED
wlan2: AP-DISABLED
wlan2: CTRL-EVENT-TERMINATING
hostapd_free_hapd_data: Interface wlan2 wasn't started
nl80211: deinit ifname=wlan2 disabled_11b_rates=0
ELOOP: remaining socket: sock=18 eloop_data=0xb6c2ec30 user_data=0 handler=0x4f5c8c

You'll need to set iw_qos_map_set to none, as @dgilman posted above. However, this should be set in radio2's wifi-iface:

config wifi-device 'radio2'
        option type 'mac80211'
        option path 'platform/soc/soc:internal-regs/f10d8000.sdhci/mmc_host/mmc0/mmc0:0001/mmc0:0001:1'
        option country 'US'
        option band '5g'
        option channel '36'
        option htmode 'HT20'
        option cell_density '0'

config wifi-iface 'default_radio2'
        option device 'radio2'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'
        option iw_qos_map_set 'none'
1 Like

I am running 21.02.1 currently. To be honest, I don’t think we need to do bisecting yet because I need to gather more details. I am actually thinking now that this is a previously known mwlwifi issue where the 5GHz band just craps out and stops working for any devices on that band. The 2.4GHz band continues fine.

So I don’t think this is an issue specific to your patch.

I tried the wifi command this time hoping that it would recover the 5GHz band but it did not. The only way to recover the 5GHz band was a full reboot of the router.

For now, I think I will just keep my wife on the 2.4GHz band because she has been getting frustrated with it.

@WildByDesign , the following could be yet another issue, but even going back to David's last build (I haven't tested anything newer yet), I've experienced a weird issue on a WRT1200AC where if I applied certain settings on the 2.4GHz radio, the 5GHz radio would die and I'd have to reboot the router to get it working again. This could just be a separate bug, but what you wrote reminded me of it. When I have a chance to test these latest builds, I'll follow up on this.

1 Like

Awesome, that worked great! Wasn't sure that was the case to even activate the interface; I use radio2 for IoT devices; still need to enable legacy 802.11b to be able to activate but other than that it looks good!

master did not fix my iPhone issue. I guess it's a bug with mt76.

looks like mwlwifi compiled from master today is not able to work as sta+ap on 5ghz radio.
edit: sorry my mistake, need edit the mac address of ap interface

so, I noticed one other issue with ARP on devices which are connected to the same WLAN after some time (~1day working).
But meanwhile ARP is working between devices connected to different interfaces(WLAN, Ethernet)

The picture is next:

  1. Devices connected to WLAN(5GHz) DO NOT respond to ARP requests from devices on the same WLAN(5GHz)
  2. Devices connected via ethernet respond to any ARP requests from WLAN(5GHz) or WLAN(2.4GHz) and vice versa!
  3. Devices connected to WLAN(2.4GHz) respond to ARP requests from devices connected to WLAN(5GHz)

@mmortal03 could it be related to the used master snapshot instead of 21.02?

@stamak , I plan on testing both snapshots, but haven't had the chance yet (my WRT1200AC is at another house in the family, so there hasn't been a good opportunity to test it yet). Are you asking about your ARP issue? I can't say -- all I can suggest is that you try that 21.02 snapshot and see if you get the same result as with the master! Let me PM you.

1 Like

Same for WRT1900ACS, do you also experience problems with Ethernet with latest snapshots or 21.02?