USER_REQUEST error when adding a VLAN

When I add a new VLAN on my Linksys EA8300 with OpenWrt 22.03.2, a USER_REQUEST error appears on the WAN interface (PPPoE) and I can't access the internet.
This is my configuration before adding a VLAN (it's the default configuration for my router):


The error appears when I add a new VLAN and set just one port (LAN 4) to untagged while also setting it to off on the default VLAN 1. After deleting the new VLAN everything goes back to normal.

Can you describe exactly what you did in terms of adding a new VLAN? What VLAN ID, what was the status on the cpu (eth0) -- tagged or untagged?

Let's also see your network config file...

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network

It happens when I add a new VLAN with everything set to OFF except LAN 4 which I set to untagged.
It also happens when I set the CPU to tagged in both VLANs.

This is my network config before adding a VLAN:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '10.10.20.10'
        option delegate '0'

config interface 'wan'
        option device 'eth1'
        option proto 'pppoe'
        option username '<my ppoe username>'
        option password '<my ppoe password>'
        option ipv6 'auto'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0 1 2 3 4'

config interface 'pro'
        option proto 'static'
        option ipaddr '10.10.10.10'
        option netmask '255.255.255.0'

config interface 'guest'
        option proto 'static'
        option ipaddr '10.10.40.10'
        option netmask '255.255.255.0'

config interface 'iot'
        option proto 'static'
        option ipaddr '10.10.30.10'
        option netmask '255.255.255.0'

config device
        option name 'eth1'

What VLAN ID did you set?

How are you connected to the router? (which network and wifi or ethernet?)

You probably need to set the CPU as tagged for VLAN 1, and then create a new VLAN (say VLAN ID 3) tagged on the CPU. Then turn VLAN 1 off on port 4 and set it to VLAN 3 untagged on port 4.

That's exactly what I'm doing but with VLAN ID 2. I'm connected via Wi-Fi (to the pro interface) but the same happens when I connect via Ethernet. As I mentioned, there is this error on the WAN interface:
image

I just tried with VLAN IDs 3, 4 and 5. It's the same.

Can you show the resultant config file after you've made the change (while the error is presenting on the wan interface)?

This is the config file after adding a VLAN (the error on the WAN interface is present):

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '10.10.20.10'
        option delegate '0'

config interface 'wan'
        option device 'eth1'
        option proto 'pppoe'
        option username '<my pppoe username>'
        option password '<my pppoe password>'
        option ipv6 'auto'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0t 1 2 3'

config interface 'pro'
        option proto 'static'
        option ipaddr '10.10.10.10'
        option netmask '255.255.255.0'

config interface 'guest'
        option proto 'static'
        option ipaddr '10.10.40.10'
        option netmask '255.255.255.0'

config interface 'iot'
        option proto 'static'
        option ipaddr '10.10.30.10'
        option netmask '255.255.255.0'

config device
        option name 'eth1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 4'
        option vid '5'

This looks fine... I'm really not sure why the error is occuring.

If you restart the router, does the error on the wan persist?

Yes, it's still there.

Some issues with your device...

Does the network actually work? The message could be spurious from LuCI.
This model has the infamous IPQ4019 chip. The advice is to run snapshot on it when you need Ethernet VLANs, as the new DSA system finally handles them properly.

2 Likes

The local network does work. Thanks for the suggestion, I'll try using a snapshot.

It works on the snapshot version, thank you!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.