Hi,
I am a newbie with OpenWrt and hope someone helps me fix the problem above.
Here's the layout:
Router TP-Link Archer C7 v2:
OpenWrt 23.05.3 r23809
Configuration using LuCI
The router connects LAN port #2 (as labeled on the back) connecting to a PFSense device. Using VLAN ID3. I configured on PFSense similar VLAN ID 3 and an DHCP server up there.
When connecting to the router using Wifi or another port, it would not be able to get an assigned IP address from DHCP server on the PFSense.
It would get an IP address: 169.254.43.156
When looked into the firewall log of PFSense, I see this:
"@2 block drop in log quick inet from 169.254.0.0/16 to any label
"Block IPv4 link-local" ridentifier 1000000101"
The IP address should be 10.0.10.x instead. On the VLAN ID3 on PFSense, I allow all network connections just to see if it works, but it does not.
The router has a DHCP client interface.
Here's the network file:
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fda0:b480:89be::/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'eth1.1'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.10.1'
option netmask '255.255.255.0'
option ip6assign '60'
config interface 'wan'
option device 'eth0.2'
option proto 'dhcp'
config interface 'wan6'
option device 'eth0.2'
option proto 'dhcpv6'
config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0t 2 3 5'
option vid '1'
config switch_vlan
option device 'switch0'
option vlan '2'
option ports '6t 1'
option vid '2'
config switch_vlan
option device 'switch0'
option vlan '3'
option ports '0t 3t 4'
option vid '3'
config device
option name 'eth1.3'
option type '8021q'
option ifname 'eth1'
option vid '3'
config interface 'children_lan'
option proto 'dhcp'
option device 'br_children'
option type 'bridge'
config device
option type 'bridge'
option name 'br_children'
list ports 'eth1.3'