Use Wan Port as Lan Port with DSA on WRT3200ACM

I upgraded my WRT3200ACM to the latest snapshot 5.4.80 Kernel and now the switch has changed to DSA. I want to use the wan port as a lan port.

below is part of my /etc/config/network

config interface 'lan'
        option type 'bridge'
        option ifname 'lan1 lan2 lan3 lan4'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.2.4'
        list dns '192.168.2.4'

config interface 'wan'
        option ifname 'wan'
        option proto 'dhcp'

config device 'wan_wan_dev'
        option name 'wan'
        option macaddr 'xx:xx:xx:xx:xx:xx'

config interface 'wan6'
        option ifname 'wan'
        option proto 'dhcpv6'

Do I only have to change this to add the wan in the lan interface and erase the wan portions?

config interface 'lan'
        option type 'bridge'
        option ifname 'wan lan1 lan2 lan3 lan4'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.2.4'
        list dns '192.168.2.4'

Thanks

Yes. You don't have to erase the wan and wan6 networks entirely, but take out the ifname 'wan' specification, making them empty stubs.

Thanks!!
I tried it and it works perfect.

It was almost too easy

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.