Use OpenSSL instead of WolfSSL on 21.0.2

Since some packages force depends on OpenSSL and these packages will install failed with Imagebuilder with version 21.02, an error like this

imagebuilder_x86_64_21_02      | Collected errors:
imagebuilder_x86_64_21_02      |  * check_data_file_clashes: Package libustream-wolfssl20201210 wants to install file /home/build/openwrt/build_dir/target-x86_64_musl/root-x86/lib/libustream-ssl.so
imagebuilder_x86_64_21_02      |        But that file is already provided by package  * libustream-openssl20201210
imagebuilder_x86_64_21_02      |  * opkg_install_cmd: Cannot install package libustream-wolfssl.

These packages work fine on 19.0x, and users can not change the package's depends

Is there any way to depends on OpenSSL without depends on WolfSSL?

2 Likes