Use extra ports on the modem as lan ports

So I currently have an openwrt router connected to a modem that has 4 ethernet port and I want to use the remaining 3 ports as lan ports for the router how can I do that

/etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd4f:82c2:2338::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option device 'wlan0'

config interface 'wan'
        option proto 'pppoe'
        option device 'eth0'
        option username '-----------------'
        option password '---------'
        option ipv6 'auto'
        option mtu '1492'

/etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/soc/3f300000.mmcnr/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
        option channel '1'
        option band '2g'
        option htmode 'HT20'
        option cell_density '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'
        option network 'lan'

/etc/config/firewall

config defaults
        option syn_flood        1
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT
# Uncomment this line to disable ipv6 rules
#       option disable_ipv6     1

config zone
        option name             lan
        list   network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT

config zone
        option name             wan
        list   network          'wan'
        list   network          'wan6'
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
        option mtu_fix          1

Are you saying that the modem has 4 ethernet ports, but not the OpenWrt device? What is the modem (make/model)? what is the OpenWrt device (make/model)?

the modem is an old tplink router that I turned into a modem in bridge mode, and the router is a raspberry pi

Is the TP Link router running OpenWrt? Which model is it?

No it is running stock os, it is tplink TD-W8950ND

Then no, unless that device has VLAN functionality exposed for user configuration (extremely unlikely).

If you want to have wired ethernet connectivity from your Pi running OpenWrt, you will need a VLAN aware (smart/managed) switch. Many routers that are supported by OpenWrt include VLAN capable switches. Or you can buy a managed switch for this purpose (do not buy an entry level model for this -- it will only cause headaches). alternatively, you can get a USB to ethernet adapter like the UE300 to have a second ethernet port that you'll use for your LAN.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.