Use a spare RT3200 as a simple wireless client

I'd like to use a spare RT3200 not as a router/firewall nor as an AP, but as a simple client device. The goal is to have it connect to my existing wireless network so I can use it as a tool for debugging.

How would I go about setting it up as such? Do I need to define the connection under wireless > Add> Mode = Client?

EDIT: Ah, I see... hit the "Scan" button, then "Join Network" on the target SSID.

EDIT2: https://openwrt.org/docs/guide-user/network/wifi/connect_client_wifi

There are a handful of ways to achieve this. Yes, setting the wireless mode to client can achieve a wireless connection to your AP. You can fast track client mode by using the scan button on your wireless radio and selecting your AP/setting up the AP credentials. This will effectively create a new interface aptly named wwan.

You can also achieve this by using Client WDS or by using 802.11s and setting up a mesh network/point. The mesh route will require you to replace your wpad-basic package with something like wpad-mesh-wolfssl on your main AP and your client node (and any other client AP’s you may have on your network).

EDIT: the mesh solution is only viable if your hardware can handle it. You can use CLI and run “iw list” to see if your hardware supports mesh point.

2 Likes

So I went with what you called the fast-track route. I see the device connected to the router, but I cannot ping nor ssh into it. Note that disabled the firewall on the device (no need for it), so that shouldn't be getting in the way.

I can only connect to the device if I use a physical network cable. Note that I assigned br-lan a static IP for this purpose, but this is only as a fall-back. Again, the primary use of this is to be a wireless client like any other phone or laptop.

Using client mode, you’ll want to use a static ip on your lan interface in the same subnet as your main AP (best if you use an ip out of your DHCP range of your main AP) and disable the DHCP. You’ll probably need to restart the interface (or even the entire device) to get the configuration working. As it is only a dumb client, you can disable dnsmasq and odhcpd as well. You can do that in the startup page.

EDIT: if you do disable dnsmasq and odhcpd, you’ll notice the software page won’t work when trying to download new packages. Disabling them doesn’t play well with opkg. You can get it working again by enabling those services and restarting them again and disabling them again when you don’t need to download or upgrade any packages.

1 Like

You could use a different ip subnet, but then you’ll need to add a route on your main AP so the subnets can talk to each other. It’s easier to use the same subnet.

I did use the same IP range for the static. I can ssh into that target IP. The wwan is on that same subnet but it got the IP assigned to it. I cannot ping or ssh to that one. I can post some config files to help.

The wwan is now effectively your wan for that device. If you’re trying to access your modem GUI by connecting to wwan, you may need to create an interface with static ip in your actual wan subnet and use @wan alias to access the modem GUI.

If accessing your modem GUI is your goal, follow this guide

I am getting confused I think...

  1. I setup the LAN interface to use a static IP (10.9.8.5).
  2. I setup the wireless client as described above and the AP assigned it (10.9.8.160)

I can ping/connect only if the network cable is attached.

On the device:

# ip a | grep 10.9
    inet 10.9.8.5/24 brd 10.9.8.255 scope global br-lan
    inet 10.9.8.160/24 brd 10.9.8.255 scope global wl1-sta0
/etc/config/network
config interface 'loopback'
  option device 'lo'
  option proto 'static'
  option ipaddr '127.0.0.1'
  option netmask '255.0.0.0'

config globals 'globals'
  option ula_prefix 'fdab:bc3e:3518::/48'

config device
  option name 'br-lan'
  option type 'bridge'
  option ipv6 '0'
  list ports 'lan1'
  list ports 'lan2'
  list ports 'lan3'
  list ports 'lan4'
  list ports 'wan'

config interface 'lan'
  option device 'br-lan'
  option proto 'static'
  option ipaddr '10.9.8.5'
  option netmask '255.255.255.0'
  option ip6assign '60'
  option delegate '0'

config device
  option name 'eth0'
  option ipv6 '0'

config device
  option name 'lan1'
  option ipv6 '0'

config device
  option name 'lan2'
  option ipv6 '0'

config device
  option name 'lan3'
  option ipv6 '0'

config device
  option name 'lan4'
  option ipv6 '0'

config device
  option name 'wan'
  option ipv6 '0'

config interface 'wwan'
  option proto 'dhcp'
/etc/config/wireless
config wifi-device 'radio0'
  option type 'mac80211'
  option path 'platform/18000000.wmac'
  option channel '1'
  option band '2g'
  option htmode 'HT20'
  option disabled '1'

config wifi-device 'radio1'
  option type 'mac80211'
  option path '1a143000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
  option channel '36'
  option band '5g'
  option htmode 'HE80'
  option cell_density '0'

config wifi-iface 'wifinet0'
  option device 'radio1'
  option mode 'sta'
  option network 'wwan'
  option ssid 'xxx'
  option bssid '24:xx:xx:xx:xx:xx'
  option encryption 'sae'
  option key 'xxx'

Also, I forgot to mention, if you want your main AP to resolve DNS and DHCP thru the dumb client, go into your DNS tab and add your main lan AP’s IP address into the DNS forward option.

I’m not seeing anything out of the ordinary in your configs, except your ipv6 is turned off on the wwan and it’s set to delegate on the lan, which is null because the wwan isn’t assigning ipv6.

Can you access luci of your dumb client in a browser using your dumb clients lan IP when connected to your wireless AP?

Yes, I can access luci to either 10.9.8.5 or 10.9.8.160 but only if the cable is connected. If I disconnect, I cannot. Same is true for ping.

Maybe I need to set the LAN interface to a different IP range like the wiki suggests, then allow the wireless connection to use the 10.9.8.* range?

EDIT: that was the problem.

1 Like

Good stuff. Sorry I haven’t used client mode in 2 years. I use 802.11s mesh to connect client routers. I’m apparently rusty.

No problem, it was I who did not follow the wiki :smiley: Thanks for your help :handshake:

Absolutely! :handshake:

Why not do WDS?

That's what I do - 2x RT3200s acting as wireless extenders connected via WDS to 1xRT3200 acting as main router. Gives WiFi throughout three floor home and garden.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.