Use 8MB of Flash in LEDE with the tiny A5-V11 mobile router

Hey!

I'm trying to get LEDE on this little neat device:

It has:

  • Build in battery with 1800mAh (with possibility to use as a powerbank)
  • SoC – Mediatek/Ralink: RT5350F MIPS processor @ 360MHz
  • Wi-Fi 802.11b/g/n up to 150 Mbps; 1x 10/100M Ethernet
  • USB – 1x USB 2.0 host port, 1x micro USB port for power/charging
  • Misc – Power LED (two colored), factory reset pinhole, button to indicate battery state (with 4 LEDs), Switch: OFF, Charging (powerbank mode), ON
  • Should have 8MB of Flash & 32MB of RAM.

Now here comes the troublebubble!


SOLVED! - Now the question is how to use all 8MB of flash (see second post!)


This "version" of A5-V11 uses the (well known) "qualcomm"-branded firmware:
So as mentiond in the openwrt wiki (https://wiki.openwrt.org/toh/unbranded/a5-v11#english_qualcomm_factory_firmware)
I did following:

  1. Catched the uboot.bin & the latest LEDE sysupgrade for this device
  2. Copy them to USB drive, rename LEDE image to firmware.bin
  3. Connected my PC to the mini router via Ethernet and power up the mini router
  4. Connect the USB Flash drive to the mini router
  5. Telnet to the mini router with the following command: telnet 192.168.169.1 (The username and password are admin)
  6. Mount the USB flash drive with the following command: mount /dev/sda1 /mnt
  7. Wait a few seconds and verify that you see files: ls /mnt
    ... I see my files, mounting worked

And next task is where things don't work out:

Nr 8. Upgrade uboot - be careful, do not reset router during and after this operation !
mtd_write write /mnt/uboot_usb_256_03.img Bootloader

But instead of:

You should see on console
#Unlocking Bootloader …
#Writing from /mnt/uboot256.img to Bootloader …  [w]

I get:
> # mtd_write write /mnt/uboot_usb_256_03.img
> Usage: mtd [ ...] [ ...]
> The device is in the format of mtdX (eg: mtd4) or its label.
> mtd recognizes these commands:
> unlock unlock the device
> erase erase all data on device
> write |- write (use - for stdin) to device
> Following options are available:
> -q quiet mode (once: no [w] on writing,
> twice: no status messages)
> -r reboot after successful command
> -e erase before executing the command
> -v output writing info. (1 more -v would output HTML format.)
> -o file offset
> -l length in file
> -w read after write action to check
> Example: To write linux.trx to mtd4 labeled as linux and reboot afterwards
> mtd -r write linux.trx linux

And I'm out :confused:

Found it!

Just missed the Bootloader in the most end of the command! Work like it should then :yum:

Now I just figured out that LEDE think's it has just 4MB of flash only:

in LuCi in the software tab there is written:

Free space: 89% (432.00 KB)

and running df -h via ssh right after install:

Filesystem Size Used Available Use% Mounted on
/dev/root 2.3M 2.3M 0 100% /rom
tmpfs 14.1M 540.0K 13.5M 4% /tmp
tmpfs 14.1M 48.0K 14.0M 0% /tmp/root
tmpfs 512.0K 0 512.0K 0% /dev
/dev/mtdblock6 484.0K 52.0K 432.0K 11% /overlay
overlayfs:/overlay 484.0K 52.0K 432.0K 11% /

And more information I can not handle: cat /proc/mtd

dev: size erasesize name
mtd0: 00030000 00001000 "u-boot"
mtd1: 00010000 00001000 "u-boot-env"
mtd2: 00010000 00001000 "factory"
mtd3: 003b0000 00001000 "firmware"
mtd4: 0011af62 00001000 "kernel"
mtd5: 0029509e 00001000 "rootfs"
mtd6: 00079000 00001000 "rootfs_data"

Question:

  1. How can I check how much flash the device has in real?
  2. How can I tell LEDE to use all of it?