USB Wi-Fi that work in OpenWrt. Please add to list

I can't get ANY internet. The way to get started isn't explained. I've setup radio1 as the access point. I want to use radio0 to find wireless internet. I've installed travelmate and the luci-app-travelmate and all the optional packages mentioned in the instructions. I've run the wizard ONCE.

Now what?

You are not going to like this but I'll own the mistake:
the wizard is to be run once after you have a working client on an outside hotspot, and an AP working accepting clients.

Having one working wireless bridge is what Travelmate uses to set itself up.
But it is not doing anything outside its package so you should be able to go into wireless, scan, join and then on the lan side join the router's AP; Travelmate should not get involved if you try that and if that works then is it is just a config issue we can work out in Travelmate.

In LuCi, when you look at the interfaces, do you see any traffic? e.g. the wan has tx and rx traffic and so does the lan?

It looks like there's traffic on the interfaces travelmate creates. But the AP has no Internet.

Your lan still has eth0 in br-lan?

Disconnect from the radio and try that.

The lan has eth0 in br-lan and internet when connected to eth0. The wireless AP does not have Internet access. Many changes have been made to the firewall by travelmate. Not sure if I should change those or if travelmate does that on the fly as part of what it's supposed to be doing.

You have it working...

I want that but I cannot find it in the US.
Any ideas?

I'm going to set this up on a pi4 this weekend just to see why I could not get it working helping in another thread and why you may also be having trouble.

AliExpress is your friend :slight_smile:

I've got my travel router setup dialed in as best as possible. The captive portal roadblock is a problem, but travelmate won't fix it. I downgraded to 22.03.6 firmware because it properly handles 'auto' channel selection where 23.05.2 does not.

I decided on installing the base firmware in ext3 over squashfs format and expanding the SD card to it's full capacity and then adding ONLY the packages I needed for it to work as a router with OpenVPN connecting to my home VPN. No problem on a 4GB mini SD card.

The simplified setup works reliably so I'm not going to "fix" it anymore. I've wasted too much time already. The old firmware seems to work better with the old hardware of the Raspberry Pi4.

I just got an ALPHA AWUS036AXM to work.
Mediatek mt9721aun chipset
OpenWRT Driver - kmod-mt7921u

There is a bug with this. When it boots - the OS does not seem to bring it up correctly - I have to go into the Web Gui and restart the wifi dongle (under wireless) - Then it seems to work fine so far. I will continue to investigate - Next step is to try
usb-modeswitch

1 Like

Finally got some little time to test a bit more on my newly purchased dongles w/Openwrt:

COMFAST WU-CF-782AC v2:
Using OpenWrt on Raspberry Pi 4B as AP, with traffic it's almost 100% dead (dongle reset), even with snapshot 6.1.82 kernel, including previous tests with other MT7612U, looks like this is dead end.

Using OpenWrt on NanoPi R4S (23.05.3) as AP, it works quite well, using my Pixel phone close to it with fast.com test I can get 540Mbps upload + 480Mbps download
Tried with laptop at about 1.5m distance with little obstacles, downloading a 5.7GB Windows ISO as test, consistently getting 35-38MB/s download without issue, so I would say this dongle works well.

Since this dongle is "multi-state", so just like what @captclearleft says, installing usb-modswitch package will solve the problem automatically.

1 Like

Tests against the other one: COMFAST WU-CF-785AC

As expected, not usable with my Raspberry Pi 4B, same reason, so I went to the NanoPi R4S route for testing. In terms of speed basically almost the same as WU-CF782AC v2, however since it has 4 antennae now, pointing to different directions giving me more coverage, in fact I am living in a house and I tried to move downstairs and the download speed can still sustain at ~350Mbps which is very good!

The casing for both 782/785 are big enough to do heat dissipation so during the download test it was just a bit warm.

BTW I forgot to mention, both devices I used WPA3 and it has no issue at all.

1 Like

I think I should give up using RPi 4B to do the test with MT7612U, even with a proposed echo 1 > /sys/module/mt76_usb/parameters/disable_usb_sg fix (Scatter-Gather issue known for some not so good USB3 controllers) it won't work on USB3 port.
However now it works on USB2 but what's the point here? The speed drops by at least 50%, NanoPi R4S surely does the job much better here.

Moved on to test using my new PIX-LINK LV-UAC04 on NanoPi R4S.
This is the single state WiFi, can be used without USB mode switch.

Ran a few tests as AP, I can get up to 520Mbps download + 430Mbps upload, which is not bad at all, but since this one has no ext. antenna like the COMFAST one, signal level is obviously lower (same test setup, COMFAST can show roughly -23dBm signal while PIX-LINK is showing -40dBm)

One interesting fact was found during test: This dongle is a bit flat & fat in shape, so I tested with angled USB3 adaptor and the dongle kept throwing error, but when I direct plug to R4S USB3 port everything works!