USB Wi-Fi that work in OpenWrt. Please add to list

Wait:

There are decent wifi cards?

Some chipsets will do AP mode so only one card is needed, if we can find it.
The alfa will do AP mode. Software AP mode but AP none the less.

I used EDUP EP-AC1605 / ALFA Network AWUS036ACM as 5ghz wifi AP for months. It didn't get hot at all and never had problems.

1 Like

Forget to mention more about the IO-DATA WHG-AC433US, this one is kind of weird when I tried to use under Linux (not limited to RPi). First it has 100% same outlook as the same IO-DATA branded WN-AC433UK, according to DeviWiki it's MT7610U, and from Windows I can see that WHG-AC433US is also 802.11ac WiFi loading a Ralink driver, I suspect they are actually the same but just different USB ID (04bb:0955).

Eventually I tested with following after installing kmod-mt76x0u:

echo 04BB 0955 > /sys/bus//usb/drivers/mt76x0u/new_id

It's recognized by the system immediately, proved that it's also MT7610U based USB dongle, I don't know if there will be any chance this USB ID got put back to linux kernel upstream, so now I have to make the above command part of the startup script in order to have it working.

Just got another USB WiFi, friend helped to get from China, it claims to be MT7612U based (model BL-R7612RD3), which is correct. Under OpenWrt it shows as AUKEY USBAC1200, however I couldn't find any matching from search.

7612

But the very first test is not that positive, the mt76x2u driver recognizes it easily, however on my RPi 4B the AP crashes almost immediately when I pass traffic on it.

Thu Jan 25 18:22:59 2024 kern.warn kernel: [ 527.994568] xhci_hcd 0000:01:00.0: WARN: TRB error for slot 2 ep 7 on endpoint
Thu Jan 25 18:22:59 2024 kern.err kernel: [ 528.001851] mt76x2u 1-1.1:1.0: tx urb failed: -84
Thu Jan 25 18:22:59 2024 kern.warn kernel: [ 528.006607] xhci_hcd 0000:01:00.0: WARN waiting for error on ep to be cleared
Thu Jan 25 18:22:59 2024 kern.err kernel: [ 528.013770] mt76x2u 1-1.1:1.0: tx urb submit failed:-22

Above log flooding in syslog, and apparently it's related to USB, I searched a bit and looks like many people reflecting same issue on Raspberry Pi 4 with various USB devices, not sure if this dongle has trouble working with RPi 4B. I will test again with NanoPi or older RPi to see how it goes later.

Note: This dongle is USB 2.0 based, so 2T2R 866Mbps can only be displayed link rate, also I can feel it a bit warm even without loading.

If it is USB2 and it claims 1200Mbps we know that math won't work.

USB2 is 480Mbps. 1d+ 1d-. I do not care what it reports. I'd unplug it, cut it open with a dremel and look at the chip itself.

If it is wasting USB2 power into heat... ...I dunno. Is it metal?
Be careful with it, it smells of fake sd cards. I'd put it on a hub and hope it frys the hub before the pi.
Thanks for trying it!

Well this is disappointing.

I tested with an old laptop with Linux, confirmed the status before putting to the RPi4

1 Like

Just now I moved this stick to NanoPi R2S, running in AP mode, this time there is no problem, AP mode runs fine, several Waveform Bufferbloat/Fast.com/Ookla Speedtest showing it's running good, temperature didn't rise up during on load.

But to my surprise, this dongle doesn't show me obvious performance increase when compared to Asus USB-AC51, I understand that USB 2.0 max. 480Mbps will be blocking the USB WiFi to attain it's max. speed, but from previous result of Asus USB-AC51, I wish this dongle can give me at least 300Mbps but no....tested many times with device sitting very close to the dongle, download speed max. 160Mbps, upload max. 230Mbps (most of the time it's just 200Mbps), I would say I definitely go for Asus one because it's a lot smaller in terms of the size.

This is promising...

Funny how life works.

I guess this won't be the issue, the device itself is USB 2.0 only, and the processor on NanoPi R2S is RK3328 which is ARM A53 with 1.5GHz based clock, it's not slow, the CPU itself should be able to handle all those with just single core (in fact the system loading is very low), so the CPU affinity probably won't help.

When I have time tomorrow, will try out NanoPi R4S (all NIC are from SoC/PCI, while the R2S LAN port is actually an USB RTL8153B NIC) to see how it goes.

But I've seen tests on some other dongle types MT7612U WiFi, probably due to bad antenna design so the performance isn't good, maybe my dongle belongs to this type.

1 Like

Just now I took RPi 4B with latest snapshot to give it a try on the previous MT7612U dongle.
Now with kernel 6.1.x, the former mentioned USB issue has gone, which matches what was observed by folks in Raspberry Pi forum, they also find that kernel 5.15.x on Raspberry Pi OS having problems when dealing with various USB devices.
I did speed test several times without issue (before it was immediately stuck when I put traffic on it) then AP crashed, I guess it could be due to the nature of "snapshot"

1 Like

Just to confirm, using older Raspberry Pi with my mt7612u dongle has no issue even with 23.05.2 release, so apparently the USB controller on RPi 4B is really picky about devices (I've also seen people getting trouble with some USB-SATA controller as well)

And to my surprise, I guess there was an update to hostapd recently? After my test with mt7612u, I plug back my COMFAST CF-953AX and now I see 6GHz available!!
Tested with my Android phone which has WiFi 6E, confirmed it's connecting with 6GHz without problem, of course my older Pi has only 100M LAN so it's only a showcase now, and I noticed that it doesn't have previous AP crashing when I put traffic on, will move back to NanoPi R4S for more tests soon.

2 Likes

Has anyone tried Amazon's best seller?:

D-Link USB WiFi Adapter Dual Band AC1300 Wireless Internet for Desktop PC Laptop Gaming MU-MIMO Windows Mac Linux Supported (DWA-181-US)

Or this, "Amazon's Choice?"

Edimax Wi-Fi 5 Nano 802.11ac AC1200 Dual-Band Adapter for PC, Wireless AC USB Adapter Dongle, Up to 867Mbps (5GHz) / 300Mbps (2.4GHz) Fast Transfer, Win 11 Plug-n-Play, Mac OS, Linux, EW-7822ULC

You can search those models on internet to check what chipset they are using, if it's Realtek then you can skip (well, most of them are Realtek)

1 Like

Both of those are Realtek. Skipping.

Recently I bought a MT7610U based (Asus USB-AC51) which satisfies me, connecting to old Raspberry Pi 1B and use it to cover a little dead zone (which only a few phones can be around) and it's fairly stable. And if you try it on newer platform like 3B+ or 4B then you can get ~200Mbps easily on 5GHz, and this is already a lot faster than the onboard 5GHz WiFi.

1 Like

Adding to the list. This dongle works as an access point on either 2.4Ghz or 5 Ghz. This adapter is on the official supported list. It is a USB 2.0 device.

Panda Wireless® PAU0B AC600 Dual Band (2.4GHz and 5GHz) Wireless N USB Adapter W/High Gain Antenna

packages required:

kmod-mt76x0u
kmod-mac80211

1 Like

From what I know all MT7610U are USB 2.0 based, BTW did you test the throughput?

I’m getting 100 mbps through the VPN which I thought was pretty good. When I connect from my desktop to the Raspberry Pi it connects with Wi-Fi 5 (802.11ac) and the Link Speed Receive/Transmit is 433/433 (Mbps). Different VPN locations have different speeds. Most are 40-60 mbps but the closest are a tick over 100 mbps.

It’s set up as a travel router getting internet over the built in radio and transmitting out the dongle as the access point, through a VPN. I have dnscrypt-proxy2 configured too. I’m debating adding ad-blocker, but the encrypted DNS servers (NextDNS) block ads too, so it's as lean and fast as I can make it.

I could do a walkthrough because it's super easy to setup through Luci and the command line if you know the basic OpenWrt quirks.

Now that I’ve finished this project finally, I’m hoping not to f it up tweaking the setup too much. I’ll be doing a little field testing on a holiday soon with this.

1 Like