USB tethering query

Folks I'm using the R7800 and was using Kong's latest build running great but based on kernal 5.x.x important features to me are predominantly wireguard and sqm.

Yesterday I decided to dip my toes and tried to install usb tethering. Following the wiki step 1 is to run opkg install kmod-usb-net-rndis

Now from my very limited understanding that won't install on a kernal v 5.x.x and it yes it failed. I chucked my second r7800 on running owrt 19.07 kernel 4.x.x and that worked. So is it possible to get working the usb tethering on the latest owrt 22 ??? If so how would you recommend I start.

Yes, it is possible (just the same way) - but…
Kernel modules have a very strict version dependency between module and running kernel, meaning they're basically only compatible for the same build (that generates kernel, installable modules and the full firmware image). For the official images, these matching modules are provided from the binary package repos, for the various stable trees and the daily snapshot builds (however here compatibility is temporary, basically only for the day when you've downloaded your snapshot image (yes, they are retained a few days more, but opkg isn't really smart enough to fetch the correct -but older- packages by default).

If you're running a non-official community build, you'd depend on the party providing the firmware images to provide these kernel module packages (building everything is a serious time sink) - if they don't build these images, you'd have to build your own from source.

1 Like

Hero. Great explanation......Thank you

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.