USB tethering on BTHH5a - no internet

I'm trying to set up a BTHH5A with 19.07.7 as a fallback device using USB tethering for internet connection. I have installed the modules for rndis etc and the tethering wan interface is present and on usb0 but no internet. The end of the kernel log shows usb0 is working

[   34.966796] br-lan: port 3(wlan0) entered disabled state
[   36.757875] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
[   36.763306] br-lan: port 2(wlan1) entered blocking state
[   36.768223] br-lan: port 2(wlan1) entered forwarding state
[   36.789444] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[   36.795198] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   36.801584] br-lan: port 3(wlan0) entered blocking state
[   36.806200] br-lan: port 3(wlan0) entered forwarding state
[   62.857823] usb 1-1: new high-speed USB device number 2 using dwc2
[   72.942024] usb 1-1: USB disconnect, device number 2
[   73.521876] usb 1-1: new high-speed USB device number 3 using dwc2
[   73.743741] rndis_host 1-1:1.0 usb0: register 'rndis_host' at usb-1e101000.usb-1, RNDIS device, da:a6:0a:3d:07:82
[  132.762326] lantiq,xrx200-net 1e108000.eth eth0: port 1 got link
[  132.767145] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[  132.777007] br-lan: port 1(eth0.1) entered blocking state
[  132.781043] br-lan: port 1(eth0.1) entered forwarding state
[  132.787677] IPv6: ADDRCONF(NETDEV_CHANGE): eth0.2: link becomes ready

this from the system log looks ok to me

Sat May  1 15:23:35 2021 kern.info kernel: [   62.857823] usb 1-1: new high-speed USB device number 2 using dwc2
Sat May  1 15:23:45 2021 kern.info kernel: [   72.942024] usb 1-1: USB disconnect, device number 2
Sat May  1 15:23:46 2021 kern.info kernel: [   73.521876] usb 1-1: new high-speed USB device number 3 using dwc2
Sat May  1 15:23:46 2021 kern.info kernel: [   73.743741] rndis_host 1-1:1.0 usb0: register 'rndis_host' at usb-1e101000.usb-1, RNDIS device, da:a6:0a:3d:07:82
Sat May  1 15:23:46 2021 daemon.notice netifd: Interface 'Tethering_wan' is enabled
Sat May  1 15:23:46 2021 daemon.notice netifd: Network device 'usb0' link is up
Sat May  1 15:23:46 2021 daemon.notice netifd: Interface 'Tethering_wan' has link connectivity
Sat May  1 15:23:46 2021 daemon.notice netifd: Interface 'Tethering_wan' is setting up now
Sat May  1 15:23:46 2021 daemon.notice netifd: Tethering_wan (2292): udhcpc: started, v1.30.1
Sat May  1 15:23:47 2021 daemon.notice netifd: Tethering_wan (2292): udhcpc: sending discover
Sat May  1 15:23:47 2021 daemon.notice netifd: Tethering_wan (2292): udhcpc: sending select for 192.168.42.80
Sat May  1 15:23:47 2021 daemon.notice netifd: Tethering_wan (2292): udhcpc: lease of 192.168.42.80 obtained, lease time 3600
Sat May  1 15:23:47 2021 daemon.notice netifd: Interface 'Tethering_wan' is now up

This is the /config/network file


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd57:c777:ae90::/48'

config atm-bridge 'atm'
	option vpi '1'
	option vci '32'
	option encaps 'llc'
	option payload 'bridged'
	option nameprefix 'dsl'

config dsl 'dsl'
	option annex 'a'
	option tone 'av'
	option ds_snr_offset '0'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device 'lan_eth0_1_dev'
	option name 'eth0.1'
	option macaddr '10:d7:b0:24:0e:96'

config interface 'wan'
	option proto 'static'
	option netmask '255.255.255.0'
	list dns '192.168.0.1'
	option ipaddr '192.168.0.209'
	option gateway '192.168.0.1'
	option ifname 'eth0.2'

config device 'wan_dsl0_dev'
	option name 'dsl0'
	option macaddr '10:d7:b0:24:0e:97'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 4 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '5 6t'

config interface 'VPNtun0'
	option ifname 'tun0'
	option proto 'none'

config interface 'Tethering_wan'
	option ifname 'usb0'
	option proto 'dhcp'

and the firewall

config defaults
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option synflood_protect '1'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	option network 'lan'

config zone

	option name 'wan'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	option network 'wan Tethering_wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fc00::/6'
	option dest_ip 'fc00::/6'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config include
	option path '/etc/firewall.user'

config zone
	option network 'VPNtun0'
	option name 'VPN_zone'
	option mtu_fix '1'
	option input 'REJECT'
	option forward 'REJECT'
	option masq '1'
	option output 'ACCEPT'

config forwarding
	option dest 'VPN_zone'
	option src 'lan'

Can anyone help find the mistake?

depending on what you want to achieve, you might need the mwan3 package.

@echidna did you get this working?

Seems to work as long as the USB is the only wan connection. I haven't tried it with multi wan.

great, did you do anything other than follow this guide: https://openwrt.org/docs/guide-user/network/wan/smartphone.usb.tethering

No, I just loaded the recommended packages. The tethering wan will not show up unless the phone is on and usb tethering is active.