USB tethering get no ip

HI all great OpenWrt people

I have a an Linksys WRT1900AC which I am trying to get USB tethering with a samsung S22.
Running 22.03.2 and following guide "Smartphone USB tethering".
I had to add usb3 support to get the android phone recognized, i get an MAC but no IP.
Some bytes are flowing Rx, TX (1 pkts)
Following the guide "Use RNDIS USB Dongle for WAN connection" under troubleshooting the /sys/kernel/debug/usb/devices is telling me how it should look like, and mine is the latter one ( with out Ad=02 (O) and AD=83) which apparently don't work.
The guide suggest modesetting may be the fault and talking about mdis_host message, since I am not sure what that means I tried to opkg install usb-modeswitch , but package could not be found.

Tried to reset my usbo interface, restart, switch and switch back interface.
And reinstalling everything again, no luck!"

Does someone have any ideas?


T:  Bus=02 Lev=01 Prnt=01 Port=01 Cnt=01 Dev#=  9 Spd=480  MxCh= 0
D:  Ver= 2.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=04e8 ProdID=6863 Rev= 5.04
S:  Manufacturer=SAMSUNG
S:  Product=SAMSUNG_Android
S:  SerialNumber=R5Cxxxxxx
C:* #Ifs= 2 Cfg#= 1 Atr=80 MxPwr=500mA
A:  FirstIf#= 0 IfCount= 2 Cls=e0(wlcon) Sub=01 Prot=03
I:* If#= 0 Alt= 0 #EPs= 1 Cls=e0(wlcon) Sub=01 Prot=03 Driver=rndis_host
E:  Ad=82(I) Atr=03(Int.) MxPS=   8 Ivl=32ms
I:* If#= 1 Alt= 0 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=rndis_host
E:  Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms


[ 4077.203834] usb 2-2: new high-speed USB device number 9 using xhci_hcd
[ 4077.398297] rndis_host 2-2:1.0 usb0: register 'rndis_host' at usb-0000:01:00.0-2, RNDIS device, f6:0f:9d:99:fb:b2

Each time you connect the phone you will need to go to the settings on the phone screen and start up USB tethering. Android doesn't allow it to be started from outside the phone for security reasons.

In OpenWrt, the usb0 device needs to be attached to an interface of proto dhcp and/or dhcp6 (DHCP Client). The DHCP client process will acquire an IP address from the phone.

Thank you,
Andriod Tethering part is working, I do approve the USB tethering on the phone.
I get as far as getting a connection, but no ip.

Here I am not sure if I understand you, I read your answer as the acquiring of an ip should happen automatically since this device if configured as dhcp client, is that right, or should I configure something more?