[usb-switchmode] usbmode - error loading shared library libjson-c

Hello community,

I encountered a problem with package usb-switchmode on OpenWRT 18.06 on my WR1043NDv1.
I am trying to use my Huawei E5577C-321 Mifi router with TP_link WR1043ND v1.8 router using USB port.
After instaling from official repository by opkg package usb-switchmod (file /sbin/usbmode) on run I get error:

Error loading shared library libjson-c.so.4: No such file or directory (needed by /sbin/usbmode)
Mifi router is not recognized correctly as network interface.

I downgraded to LEDE 17.05.7 and problem with usb-switchmode does not occur.
I retested with with my Raspberry Pi Zero using Openwrt 18.06.1 and problem witch usb-switchmode also does not occur.
I think this is problem with mips_24kc package (usb-switchmode).

Did anyone encountered this problem?

Best Regards,


there have been issues with the repositories leading to inconsistent state of packages. This has been fixed now.

Please try

opkg remove usb-modeswitch
opkg update
opkg install usb-modeswitch

I tried this and also:
Fresh install of openwrt 18.06, opkg update,opkg install usb-modeswitch.

Every time same error.

When did you try the last time? The repo was only fixed two hours ago. I just checked https://downloads.openwrt.org/releases/packages-18.06/mips_24kc/base/usb-modeswitch_2017-12-19-f40f84c2-1_mips_24kc.ipk and it links libjson-c.so.2 as expected and not libjson-c.so.4 anymore.

I tried this yersterday around 20:00 (GMT+2) but since there were problems with repo I used mirror from Poland for 18.06.2 and mirror from Netherlands for 18.06.1.
If packet usb-switchmode on mirrors was not reliable (?) I can retry today evening using primary repo.

@ jow
I retested procedure you send on a fresh install of openwrt 18.06.2 and it worked.
Thank you.

Was there an issue with usb-modeswitch packet earlier?

There was a problem with builds during the last day or two that had the wrong things in the wrong place for just about everything. It has since been resolved.

1 Like

The story behind this:

Thank you @tmomas, @jeff, @jow
That covers all my questions.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.