USB storage, Archer C7 V4.0 with OpenWrt 18.06.1

I'm trying to set up USB storage on a TP-Link Archer C7 V4.0 running OpenWRT 18.06.1, following the instructions here:
I have installed kmod-usb-storage and kmod-fs-fat

I have two problems, one minor, one major:

  1. (minor) Package "usbutils" does not appear to be available
  2. (major) When I plug in a USB storage device nothing happens. Specifically:
  • dmesg shows no output indicating an USB device has been attached
  • No "sd..." devices are shown in /dev
  • No lights appear, either on the USB device, or the USB lights on the router

Can anyone suggest what I can try next?



The kmod-usb2 did not get included in the build though it should have been. Most models with USB ports include kmod-usb-core and kmod-usb2, but this one does not. So install kmod-usb2, which should automatically also install kmod-usb-core as a dependency.

The kmod-usb-core is responsible for the "new speed USB device detected" kernel message. This then triggers udev to search for an installed high-level driver for the device.

The USB port LEDs also never light up on my C7v4 but that is a minor concern.

1 Like

Thanks, mk24 - installing kmod-usb2 seems to have done the trick.

If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)

You can also mark the reply that solved your problem:

I am curious if installing kmod-usb2 is the fix, or will just installing kmod-usb-core be sufficient ?

The reason I ask is that 18.6.x seems to have a new kmod-usb-dwc2 to handle usb2 and kmod-usb-dwc3 to handle usb3.

Hi can you describe (or provide link) to how you installed OpenWRT on V4.0? Which version of OpenWrt did you use and web interface or TFTP? Thanks kindly.

Since your question does not seem to be related to USB storage, please open a new topic for your question.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.