USB EXT4 fs Size not to the full partition size

I have a 3TB USB disk /dev/sda1 with a single EXT4 Partition.
I want the filesystem to use the whole partition but the fs appears to be only about 11MB and showing 82% utilised

OpenWrt 19.07.7 r11306-c4a6851c72 / LuCI openwrt-19.07 branch git-21.086.32701-7456e2a

df mnt/
The filesystem has approx 10MB in use and is showing as 81% full

Filesystem           1K-blocks      Used Available Use% Mounted on
overlayfs:/overlay       12032      9776      2256  **81% /**
fdisk -L 
Disk /dev/sda: 2.75 TiB, 3000558944256 bytes, 5860466688 sectors
Disk model: Elements 25A2
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 4777D3F9-9DC0-49E5-B120-EE598CE75AEE

/dev/sda1: UUID="a803e30b-7dbd-4210-ae27-90e399e802c7" VERSION="1.0" TYPE="ext4"

I have tried resize but this seems to say the fs it max size :-

root@OpenWrt:~# resize2fs /dev/sda1
resize2fs 1.44.5 (15-Dec-2018)
The filesystem is already 732557824 (4k) blocks long.  Nothing to do!

I want the filesystem to use the whole partition?
I am new to openwrt/Linux, please can you point me in the right direction.
Thanks in advance.


Looks like your overlay is not mounted properly, make sure to follow the guide:

My objective was only to mount additional file space for general usage, if I have understood Extroot correctly that is to move the root file system to an external drive?

vgaetera, thanks

I ran through the mount process again and it's now correct.
learning for me, my counfusion between /dev/sda1 and /mnt/sda1

Do I need to close this topic?

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.