USB Eth Adapter

Not sure what the root cause is, but I have a pi 4 with three of the same usb ethernet adapters Bus 002 Device 005: ID 0b95:1790 ASIX AX88179A Bus 001 Device 004: ID 0b95:1790 ASIX AX88179A Bus 001 Device 002: ID 2109:3431 USB2.0 Hub Bus 001 Device 001: ID 1d6b:0002 Linux 5.15.150 xhci-hcd xHCI Host Controller Bus 002 Device 004: ID 0b95:1790 ASIX AX88179A Bus 002 Device 001: ID 1d6b:0003 Linux 5.15.150 xhci-hcd xHCI Host Controller

It has worked fine for a while now, but I have a new mobo on one of the clients and it has a RTL8125BG adapter which was making one of the usb adapters crash with this ERROR Transfer event TRB DMA ptr not part of current TD ep_index 5 comp_code 1 openwrt

Anyway turning off power savings in the driver options for the RTL8125BG seems to have fixed it for now. Any ideas on what would cause that error?

Nevermind its spamming that in the system log again

If you use three backticks it does not.

It seems it may be using the usb2 port causes the issue

Plese show (enclosed in triple backtics ```) output of:

ubus call system board
lsusb -t

Are you using a powered USB hub ?

1 Like

''' "kernel": "5.15.150",
"hostname": "OpenWrt",
"system": "ARMv8 Processor rev 3",
"model": "Raspberry Pi 4 Model B Rev 1.5",
"board_name": "raspberrypi,4-model-b",
"rootfs_type": "ext4",
"release": {
"distribution": "OpenWrt",
"version": "23.05.3",
"revision": "r23809-234f1a2efa",
"target": "bcm27xx/bcm2711",
"description": "OpenWrt 23.05.3 r23809-234f1a2efa"'''

'''/: Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/4p, 5000M
|__ Port 1: Dev 4, If 0, Class=, Driver=ax88179_178a, 5000M
|__ Port 2: Dev 5, If 0, Class=, Driver=ax88179_178a, 5000M
/: Bus 01.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/1p, 480M
|__ Port 1: Dev 2, If 0, Class=, Driver=hub/4p, 480M
|__ Port 3: Dev 4, If 0, Class=, Driver=ax88179_178a, 480M'''

No not using any usb hub, just the built in nic and the two usb3 adapters and one usb3 adapter in the usb2 port.

You are using the built in nic as wan?

And USB3 NIC in USB2 port does not have any traffic pacing option and you get those kernel log messages on every dropped packet. Works as designed.

Is there any workaround for compatibility? Also built in nic is used for AP with vlans for separate ssids. Wan is on one of the usb3 adapters

Not optimal.

Maybe/probably not the reason for your, particular, issue but RPi4 should use its nic as wan.

AP doesn't have multiple ethernet ports ?

Yeah, I, also, think we are missing critical information on why the set-up is as is.

There must be a cleaner way to achieve their goals.

Nah its a EAP610

Would you please diagram how your network is setup?

We might not need to drag this out when something like an 8 port smart switch could/would not only fix this issue but, also, provide a more robust network.

I really only need the one extra port going to a client device at that location so I'd prefer not to add a switch. It seems the usb3 adapter on the usb2 port just isn't going to work for some reason.

I just had to rearrange that for context.

When you are ready to clean up your network, we'll still be here to help.

If we only understood your network, your goals and your network layout; as previously, and politely, asked...
Arguing with us won't help.
You have said this twice; which makes me wonder if you have not already solved it(?):

And I'll actually bet you money it is not a USB2 issue.
You have data coming in the USB line and going out the dedicated data line (which is a lot of USB scheduling conflicts). (yes, that is a ridiculously dumbed-down phrasing)

And we still do not understand what you are trying to do.
Have you even tried plugging the 'mobo' into one of the USB3 ported adapters? (well, you only have one because you have wasted another with WAN).

Anyway, fairly sure this is fixable, if you help yourself more with answering questions.

It seems to be a kernel or driver issue with 23. I reverted it back to 22 without changing anything and it works fine.

1 Like

If true, (actually, even, insinuated) OpenWrt will look into it.