Usb dongle driver

hi, ive been trying to configure my usb wifi dongel. Except it doesnt seem to work. i tried installing the driver for it, or atleast tried to find it, but couldnt really find it

when i do ifconfig wlan1 up i get the error "ifconfig: SIOCGIFFLAGS: No such device
"

when i type lsusb i get this output

Bus 001 Device 005: ID 0424:7800  
Bus 001 Device 003: ID 0424:2514  
Bus 001 Device 006: ID 0bda:8172 Manufacturer Realtek  RTL8191S WLAN Adapter 
Bus 001 Device 002: ID 0424:2514  
Bus 001 Device 001: ID 1d6b:0002 Linux 5.15.134 dwc_otg_hcd DWC OTG Controller

its the realtek one.
and when i type dmesg i get

[  466.040845] usb 1-1.3: new high-speed USB device number 6 using dwc_otg
[  466.173274] usb 1-1.3: New USB device found, idVendor=0bda, idProduct=8172, bcdDevice= 2.00
[  466.186073] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  466.195713] usb 1-1.3: Product: RTL8191S WLAN Adapter 
[  466.203104] usb 1-1.3: Manufacturer: Manufacturer Realtek 
[  466.210780] usb 1-1.3: SerialNumber: 00e04c000001

i did find the driver but its the SU variant, and i dont know if this is just a variant that isnt supported or not.

can anyone help?

Realtek is usually a dead end.

what kind of dongle should i go for then?

MediaTek

1 Like

…and ideally none at all, but using some OpenWrt supported AP instead (e.g. something mt7621a+mt7915DBDC based starting around 20 EUR).

This topic https://forum.openwrt.org/t/usb-wi-fi-that-work-in-openwrt-please-add-to-list/ might provide you with some options

2 Likes