Uqmi -d /dev/cdc-wdm0 --list-messages not return any message

I have TL-MR6400 4G-LTE router:
Hostname: OpenWrt
Model: TP-Link TL-MR6400 v5
Architecture: MediaTek MT7628AN ver:1 eco:2
Target Platform: ramips/mt76x8
Firmware Version: OpenWrt 21.02.3 r16554-1d4dea6d4f / LuCI openwrt-21.02 branch git-22.083.69138-0a0ce2a
Kernel Version: 5.4.188

"uqmi -d /dev/cdc-wdm0 --send-message ......" working fine,
but "uqmi -d /dev/cdc-wdm0 --list-messages" return empty list all the time.

did i miss anything?

An LTE device can store the received text messages either on the SIMcard or in the internal memory. The LTE device in MR6400v5 stores the text messages in the internal memory.
The version of uqmi, in 21.02.3, does not support reading messages from the internal memory, just from SIMcard. Next release in 22.02 will support it.

You can compile your own version based on next release.
I have a modified version which include support of reading text messages from internal memory.
They are available at: https://github.com/mrhaav/openwrt/tree/master/21.02.3


I tried to install modified version but I got below error:
pkg_init_from_file: Malformed package file uqmi_2022-03-15-0.4_mipsel_24kc.ipk
also i tried to install 0.5 but same error
pkg_init_from_file: Malformed package file uqmi_2022-05-16-0.5_mipsel_24kc.ipk

Did you download from your router with:

wget https://github.com/mrhaav/openwrt/raw/master/21.02.3/uqmi_2022-03-15-0.4_mipsel_24kc.ipk

sorry, i were trying to install it from
wget https://github.com/mrhaav/openwrt/blob/master/21.02.3/uqmi_2022-03-15-0.4_mipsel_24kc.ipk

i install it now, and created the two file "uqmi_led.sh" & "uqmi_sms.sh" then i make them executable, chmod +x, then tried to send sms to router sim card not still list-messages return
I noticed that there is no path /var/sms, even after i created it, it's keeps empty

Sorry, the daemon is not included in uqmi_2022-03-15-0.4_mipsel_24kc.ipk. You need to download and install uqmi_2022-05-16-0.5_mipsel_24kc.ipk

But, uqmi_2022-03-15-0.4_mipsel_24kc.ipk does support reading text messages from internal memory.
You need to add --storage me to uqmi -d /dev/cdc-wdm0 --list-messages

uqmi -d /dev/cdc-wdm0 --list-messages --storage me

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.