uPnP/DLNA discovery issue on bridged WLAN


I have the below issue with the discovery and access of uPnP devices in my network. The environment is the following:

The main OpenWRT router in the network is wired only. This goes to a switch. I have a server running uPnP and multimedia content, connected to the switch also trough Ethernet. There is a OpenWRT router, acting as an access point only, connected to the switch as well. Smart TV connected wirelessly to the OpenWRT access point.

  • The main OpenWRT router: MikroTik RouterBOARD 450G, OpenWrt SFE r10912-d94a3f328f / LuCI ( Trunk ), kernel 4.14.141, dhcp, firewall, etc. all enabled
  • The OpenWRT AP:TP-Link Archer C7 v5, OpenWrt SFE r11009-1cf2495d48 / LuCI ( Trunk ), kernel 4.19.72, firewall service and firewall zones disabled, dhcp, disabled, configured for "dumb" ap mode only, 2.4 and 5Ghz radios bridged together with Ethernet.

The problem:

  • The uPnP server is not detected/discoverable/not visible on the devices which are connected through WiFi, tried it on the Smart TV and from my mobile phone (Android - VLC media player)
  • From my desktop PC connected through Ethernet to the switch, it is discovered and listed (Windows Explorer, VLC)

"Enable IGMP snooping" option under LAN bridge settings on the AP is enabled. I tried different uPnP servers, (was Emby, now Jellyfin), that is not the issue, I can enable multiple different ones, on Ethernet is all good, but not on WiFi any more. I remember this used to work before. Currently I am unable to play content on my shiny new TV. Are there any ideas what can I try to troubleshoot this issue?

Thank You,

I would first check that arp table is correct on the DLNA server and on the C7.
Then run tcpdump on C7 to verify that packets are coming in and going out for the DLNA.

It seems that the OpenWRT build I was using was at fault. I have been using a build based on the latest snapshot, and it seems to be proper now.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.