UPnP client, wan passthrough firewall setting?

Hey fellas

I have an openwrt unit behind another router with upnp enabled.

In order for the upnpc client to be able to communicate with the other router (through the wan interface) I have to (reluctantly) create the firewall rule to enable "All protocols" to be forwarded from "wan" to "This device" which can't be good.

I tried forwarding 1900udp and 5000tcp but if I do I get "No IGD device detected".

I even tried to forward every protocol to 1900+5000 but still the same error.

It appears that no other setting than "All protocols" (which disables the port number option) is working. What gives? Anyone got a clue?

When it's working it says that it's using port 1900. But if I only open 1900 it doesn't work. It seems to use a protocol that isn't listed in the firewall rule settings so that only "All protocols" is effective.

Thank you very much for reading and commenting.