Uploading the original firmware to the Netgear D7800

I apologize in advance for not being able to speak English and using translator.
Please help if any of you have experience uploading the original firmware to the Netgear D7800 - AC2600 VDSL / ADSL WiFi router. I now have OpenWrt installed on the router. The firmware cannot be recovered directly because it does not have the * .img extension that the firmware for Netgear has. I also failed to load the firmware using TFTP and Netgear's SW. So one of you should not experience or at least reference where I can find the exact recovery process.
Thanks in advance, Tomas.

I would assume a variation of https://openwrt.org/toh/netgear/r7800#debricking to work, with the correct firmware for your device of course.

1 Like

slh is right, use the latest stock FW from Netgear. I used Debian from the Windows store, just set your ethernet adaptor to a static IP 192.168.1.x and install tftp on Debian with:

sudo apt-get install tftp

Place your factory FW somewhere where you can reach it from Debian, say in D:\temp, then you can copy it to the Debian location with:

cp /mnt/d/temp/factory-firmware.img .

Turn the modem off, wait for 10 seconds, then back on and wait until as soon as the power button blinks white steady, then enter the commands:

put factory-firmware.img

If all goes well you will see Sent xxx bytes and your modem will reboot a few times as it installs the firmware, and after a few minutes it will be working on the factory image. Initially I tried forcing the install at the openwrt ssh shell and bricked my D7800 (it was boot looping with no web interface or access to SSH terminal). After holding reset to get it into the bootloader mode (steady flashing white power light) where I used the tftp windows client to place openwrt back onto it. Another trick to achieve bootloader mode while boot looping was to have an ethernet cable connected back to the PC while holding the factory reset button, without the connection it just kept boot looping. The windows GUI client did not work to restore back to the factory image, each time it would get to around halfway done and fail. The tftp prompt in Debian worked first time.

Edit: I did get a couple of screenshots.

What not to do (how to brick the device into a boot loop):


The recovery process (I can't put more than one image in a post)...


Hi, thank you very much for the information.
I will try to look at it and do it according to your instructions if it will work. Then I'll let you know how it went, if I ask you for help.

Just a small update to this. To restore the factory image from working openwrt, turn the D7800 off, hold reset, then turn it on with reset still held. Keep holding reset until the power light is flashing white. Now follow the tftp commands in the above grab. Doing it this way, it will take 5-6 minutes before it says transfer complete, then the D7800 will reboot a few times and will be back to factory.

Slightly off-topic, but is it possible to flash OpenWrt from the D7800's web interface or is tftp required? I've never used tftp, so I'm wondering if it would be overly complicated and a reason for me to choose another device. The R7800 isn't available in Australia and I'm guessing the D7800 is close enough in terms of specs that I wouldn't notice a difference in performance once OpenWrt has been installed.

While I don't have the device in question, installing via tftp will be required as the originial OEM partitioning didn't reserve enough space for the kernel (2 MB), which had to be changed for current OpenWrt.

Many thanks to you all for your help. Finally, I managed to run the router according to your instructions. Obviously I had a badly prepared router by not holding the reset button at power up and holding it long enough so I didn't have active recovery mode. Then he went to the router to upload firmware using TFTP client.
Thank you once again.

If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)