Upload Problem, timeout when uploading at max speed

I am new to Openwrt and noob in networking in general. I have a new TP-Link TL-WR902AC. As the title says, whenever I upload at my max internet speed (not max router speed) my router always timeout, it happens usually like 4 seconds after the upload starts. I know this is my router's problem (not my ISP) because while uploading, I tried pinging my router ( from my phone and it still timeout. And this doesn't happen with download as far as I know. Latency rise but doesn't timeout.

Since I am a noob, I don't know what settings I should change. I'd be glad if anyone can help me out, thanks.

PS : My internet speed is around 100mbit/sec while my router max speed is around 500mbit/sec? So, I am assuming reaching speed limit shouldn't be the issue, plus the problem doesn't happen with download.

Watch the upload speed, and when it drops/stops, cancel the upload.
How long does it take for the router to recover (respond to ping again)?
After recovery, does the uptime show a low value (~1 minute), indicating the router has restarted?

Which version of the TP-Link TL-WR902AC do you have, and which OpenWrt release is installed on it?

The recovery doesn't take long, and it differs. 2-5 seconds I'd say. Here is a screenshot of my router ping during a speed test on speedtest.net

I have the V3 and there seems to be only one firmware version for this router (19.07.4) LINK

Good, the router does not seem to restart, this is just a temporary overload or overbuffering.

According to the techdata, this router has a single ethernet port at 100 Mbit/s.

Do you connect the wired ethernet to your ISP, and the clients via wireless to the router?

Which frequency band do you use for your clients?

WiFi appears to be dual-band, so I would suggest an experiment:
Try to connect the uploading client via 5 GHz and the phone via 2.4 GHz. Does ping from the phone still fail during the upload?

Also check the log for anything suspicious: run logread -f in parallel to your experiments.

My setup is pretty unusual lol. My ISP is wireless and I use my main router (the WR902AC) in client mode to connect to the ISP at 5GHz band. And I have another router (WR740N v2) which I use as a regular router for clients; PC is wired to the secondary router and phone is on wireless.
(Note : The second router doesn't seem to have anything to do with the problem as I have checked without it and result was the same).

I don't utilize the 2GHz band on the main router and is currently idle/disabled.

Sorry mate, I am completely lost here, I don't know how to check logs at all. Can you help me out? XD

Thanks, this is important information.
Is the uplink of the secondary router connected using its WAN port, or one of its LAN ports?

  • In OpenWrt's web interface (LuCI), click menu items Status->System Log or Status->Kernel Log. Most interesting would be any messages that appear during the speed test. You may have to click the menu item again to see new messages.


  • use an SSH client (PuTTY or the ssh command built in to Windows 10) to connect to the router, then type the command
    logread -f
    When done, press Ctrl-C to terminate the logread, and Ctrl-D to log out.

But let us try something else first:

  • Set up SQM on the main router. However, do not run a speed test to find your down/upload link speeds, just enter 50000 kbit/s for each.
  • Connect the speedtest client to the primary router, to rule out any interference from the secondary router.
  • Perhaps enable 2 GHz WiFi on the primary router to run a ping test from the phone.

If this gets you a stable upload speed, then we can start optimizing this configuration further.

I haven't been replying because I have another issue. I had this issue when I first use this router as well. My download speed is limited to around 25mbps and upload to around 70mbps for some reason. I initially fix the problem by using the "Force 40MHz mode" in advanced settings, I thought that was it and tried to move on, but the problem is back and sometimes changing the channel width doesn't fix it and sometimes it does.

With this issue, I can't even recreate our original problem in discussion properly. I am wondering if I should create another thread for this?

I have installed SQM as you suggested but I haven't touched any settings yet. No download/upload speed limitation there.

Yes, please open another thread for this issue.

Update: This seems to be the new thread mentioned above.

Then SQM is not enabled and should not do anything.