Uplink port not negotiating gigabit speed after 21.02 update

I have a Buffalo WZR-HP-AG300H that I use as AP. After updating it to 21.02.0, the uplink port eth1 that is connected to a switch is negotiating at 100 Mb/s.

I'm sure that before the upgrade this link was working at 1000Mb/s. I've tested the cable and is perfectly fine and if I force the 1000 Mb speed in the switch the link is marked as down. Also 1000BaseT is no longer advertised as a supported mode in ethtool.

I've already workarounded the issue using an unused port in the internal switch, but it'd be nice if it can be fixed.


# ethtool eth1
Settings for eth1:
	Supported ports: [ TP MII ]
	Supported link modes:   10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	Supported pause frame use: Symmetric Receive-only
	Supports auto-negotiation: Yes
	Supported FEC modes: Not reported
	Advertised link modes:  10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	Advertised pause frame use: No
	Advertised auto-negotiation: Yes
	Advertised FEC modes: Not reported
	Link partner advertised link modes:  10baseT/Half 10baseT/Full 
	                                     100baseT/Half 100baseT/Full 
	Link partner advertised pause frame use: No
	Link partner advertised auto-negotiation: Yes
	Link partner advertised FEC modes: Not reported
	Speed: 100Mb/s
	Duplex: Full
	Port: MII
	Transceiver: external
	Auto-negotiation: on
	Current message level: 0x000000ff (255)
			       drv probe link timer ifdown ifup rx_err tx_err
	Link detected: yes

# dmesg | grep eth1
[    2.579283] eth1: Atheros AG71xx at 0xba000000, irq 5, mode: rgmii
[   76.682973] eth1: link up (100Mbps/Full duplex)

# uname -a
Linux gluon 5.4.143 #0 Tue Aug 31 22:20:08 2021 mips GNU/Linux

Did this speed degradation occur only to port 1 or to the other 4 ports too?

I am seeing the same behavior on my Ubiquiti RouterStation Pro. I wrote it up in this thread. Since my device isn't all that common these days, I haven't seen any responses (and I'm not optimistic), but with any luck we're actually looking at the same issue/bug such that we might find the same/similar resolution.

1 Like

This happens only on eth1 which is the WAN port. The other LAN ports are part of the switch and they are working at 1000 Mb/s just fine.

1 Like

If you look back at my thread (linked previously), I have updated the info there with confirmation that this is a 21.02.0 bug that does not present in 19.07.8.

I filed a bug and linked it in my original thread.

Thank you, I'll watch the bug.

On my WZR-600DHP, with hardware that may be identical to WZR-HP-AG300H, this problem is already solved in master branch via https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=766e0f584a325b0b80a97bbc86ca515d97c63001

You can git cherry-pick 766e0f584a325b0b80a97bbc86ca515d97c63001 and then build 21.02.0 with working gigabit. It would be nice if this fix gets included in future releases of version 21.

The fix has also worked on RouterStation Pro.


I can confirm that the commit has made it into 21.02.1 and fixes the issue on my RouterStation Pro. I expect that it will fix the problem on your Buffalo device, too.


I just tested, and yes, it's fixed in 21.02.1 for my Buffalo WZR-HP-AG300H.

Many thanks!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.