I had my WR841ND running 15.05 for a long time. I decided to upgrade and found it would upgrade to 18.06.9 so I downloaded 17.x latest upgrade and applied without any problems. Then I applied openwrt-18.06.8-ar71xx-tiny-tl-wr841-v9-squashfs-sysupgrade.bin
If this I received:
/usr/lib/lua/luci/dispatcher.lua:234: /etc/config/luci seems to be corrupt, unable to find section 'main'
[C]: in function 'assert'
/usr/lib/lua/luci/dispatcher.lua:234: in function 'dispatch'
/usr/lib/lua/luci/dispatcher.lua:127: in function </usr/lib/lua/luci/dispatcher.lua:126>
when trying to login.
I found issues similar and made some of the changes they recommended but without any resolution.
/etc/config/luci now has:
config core 'main'
option lang 'auto'
option mediaurlbase '/luci-static/bootstrap'
option resourcebase '/luci-static/resources'
config extern 'flash_keep'
option uci '/etc/config/'
option dropbear '/etc/dropbear/'
option openvpn '/etc/openvpn/'
option passwd '/etc/passwd'
option opkg '/etc/opkg.conf'
option firewall '/etc/firewall.user'
option uploads '/lib/uci/upload/'
config internal 'languages'
option en 'english'
config internal 'sauth'
option sessionpath '/tmp/luci-sessions'
option sessiontime '3600'
config internal 'ccache'
option enable '1'
config internal 'themes'
option Bootstrap '/luci-static/bootstrap'
18.06 is EOL. Besides that, did you tick 'Keep configs'? Bad idea when moving between major releases.
The WR814 page says 18.06.9 is the latest stable for v9 of the hardware.
How do I resolve this?
It's probably due to the 4/32 issue.
4/32 warning Devices that have only 4 MBytes of Flash memory or only 32 MBytes of RAM are unlikely to work with modern versions of OpenWrt (19.07, 20.0x, and newer). Here's why: Every operating system requires * Sufficient Flash to...
This is a package of OpenWRT 19.07.1 stable builds for targets ath79.
Modifications against default tiny packages:
removed PPP support package
removed OPKG package
This way the builds could fit into squashfs (factory/sysupgrade) compatible builds.
Please note there is still upgrading incompatibility against deprecated target ar71xx (OpenWRT version 18.06 or older), please see
https://openwrt.org/docs/guide-user/installation/ar71xx.to.ath79 for more info.
Builds have not been…
Or get a new device.
Does this apply to v9 hardware as well?
I though that was what this thread was about...?
Since you've been tinkering with the files in this new install, definitely now you need to run firstboot or use the reset button to return the system to defaults.
When LuCI doesn't load properly on your browser, first thing to try is clear the browser cache.
So I started by restoring the original firmware then applied 15.05 and 17.01.7 then 19.07.-ath79-tiny
I did have to do a hardware reset after 19.07 and configure again.
All working fine now.
This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.