Upgrading TpLink Archer C2 AC750 v1 to latest sysupgrade package fails

I'm struggling to get openwrt going on this old archer c2

At first I tried prepping my own package and flashing it with tftp as per the instructions on this page
https://openwrt.org/toh/tp-link/archer_c2_ac750

That seemed to fail, the router would download the package from the tftp server and then nothing, even when left alone overnight.

So then i flashed the recovery image found here (link also found on the previously mentioned page)
https://forum.archive.openwrt.org/viewtopic.php?id=52625&p=5#p347582

That worked like a charm

Then i tried to sysupgrade to the latest supported version (23.05.3) found here
https://forum.archive.openwrt.org/viewtopic.php?id=52625&p=5#p347582

The sysupgrade seems to do its thing but the router becomes completely unresponsive, i can recovery mode back to the other version just fine.

opkg update fails with:
Signature check failed.
Remove wrong Signature file.

output of ubus call system board; cat /etc/openwrt_release:

{
"kernel": "4.4.14",
"hostname": "OpenWrt",
"system": "MediaTek MT7620A ver:2 eco:6",
"model": "TP-Link Archer C2",
"release": {
"distribution": "OpenWrt",
"version": "Bleeding Edge",
"revision": "50020",
"codename": "designated_driver",
"target": "ramips\/mt7620",
"description": "OpenWrt Designated Driver 50020"
}
}
DISTRIB_ID='OpenWrt'
DISTRIB_RELEASE='Bleeding Edge'
DISTRIB_REVISION='50020'
DISTRIB_CODENAME='designated_driver'
DISTRIB_TARGET='ramips/mt7620'
DISTRIB_DESCRIPTION='OpenWrt Designated Driver 50020'
DISTRIB_TAINTS='no-all'

tia

Note that you are using some non-release OpenWRT, so you need to reset configuration when installing latest sysupgrade.
https://firmware-selector.openwrt.org/?version=23.05.3&target=ramips%2Fmt7620&id=tplink_archer-c2-v1
Worth backing up configuration, then manually restoring customization to new config files via luci.
Also save opkg list-installed - it may keep some extra packages you had in that custom distro.
For long-term maintenance install luci-app-attendedsysypgrade to have package upgrades go directly to rootfs and never get duplicates in overlay.

... if it doesn't work, upgrade in steps, going up one release at a time, resetting the settings every time.