Upgrading to 23.05 breaks WDS

Hi

I have 2 OpenWrt box connecting through WDS (wireless). No encryption set.

This worked fined for years.
Upgrading to 23.05 broke the setup

Any one has experienced it ?
How have you solved it , besides going back to 22.03 ?

Thank you

Are you running the same version on both ends? What device model(s) are you using?

WDS works for me on Linksys E8450 (main router) + Netgear WAX202 (WDS repeater).

1 Like

Yes, same version on each. not the same brand name though.
But I had no problems with 22.03

only 23.05 creates a problem:

The network link is established (wifi connects), but IP packets do not go through

What are the two devices in question? Did you keep settings across the upgrades (or restore from a backup after)?

I clicked on "keep the settings".
Devices Comfast WR650 and Kuwifi (Yuncore) 830

To be more precise:

  • First release (beta) of 23.05 has been working fine.
  • I upgraded this week to stable, then it stopped working

Additionally, I get in the logs:

dnsmasq-dhcp[2744]: DHCP packet received on phy1-ap0.sta1 which has no address

Let’s see your configs from both devices.

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
1 Like

Device client

# ubus call system board
{
        "kernel": "5.15.137",
        "hostname": "cpe-terrace",
        "system": "Qualcomm Atheros QCA9533 ver 2 rev 0",
        "model": "YunCore/KuWfi CPE830(D)",
        "board_name": "yuncore,cpe830",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05-SNAPSHOT",
                "revision": "r23613-2285eb732a",
                "target": "ath79/generic",
                "description": "OpenWrt 23.05-SNAPSHOT r23613-2285eb732a"
        }
}

# cat /etc/config/firewall

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config include
        option path '/etc/firewall.user'

config zone
        option name 'LANHOME'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'

# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config device
        option name 'br-lan'
        option type 'bridge'
        option bridge_empty '1'
        option stp '1'
        option igmp_snooping '1'
        option ipv6 '0'
        list ports 'eth0'
        list ports 'eth1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.12'
        option netmask '255.255.0.0'
        list dns '192.168.1.11'
        list dns_search 'maduao.net'
        option gateway '192.168.1.11'
        option delegate '0'

config device
        option name 'eth0'
        option ipv6 '0'

config device
        option name 'eth1'
        option ipv6 '0'

config device
        option name 'phy0-ap0'
        option ipv6 '0'

config device
        option name 'phy0-ap1'
        option ipv6 '0'

config device
        option name 'phy0-sta0'
        option ipv6 '0'

# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option band '2g'
        option htmode 'HT20'
        option country 'US'
        option channel '1'
        option path 'platform/ahb/18100000.wmac'
        option cell_density '1'
        option txpower '28'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'CAMERA'
        option key 'ZZZZZZZZZZ'
        option encryption 'psk'
        option short_preamble '0'
        option macfilter 'allow'
        option max_inactivity '60'
        list maclist 'YYYYYYYYYYY'

config wifi-iface 'wifinet0'
        option device 'radio0'
        option mode 'ap'
        option ssid 'HOME'
        option network 'lan'
        option key 'UUUUUUUUUUUUU'
        option encryption 'psk'
        option short_preamble '0'
        list maclist 'XXXXXXXXXXXXX'
        option macfilter 'allow'

config wifi-iface 'wifinet1'
        option device 'radio0'
        option mode 'sta'
        option key '1'
        option ssid 'BRIDGEID'
        option network 'lan'
        option encryption 'none'
        option short_preamble '0'
        option wds '1'

Device master

# ubus call system board
{
        "kernel": "5.15.137",
        "hostname": "wifi-indoor",
        "system": "Qualcomm Atheros QCA9558 ver 1 rev 0",
        "model": "Comfast CF-WR650AC v2",
        "board_name": "comfast,cf-wr650ac-v2",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05-SNAPSHOT",
                "revision": "r23613-2285eb732a",
                "target": "ath79/generic",
                "description": "OpenWrt 23.05-SNAPSHOT r23613-2285eb732a"
        }
}

# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config device
        option name 'br-lan'
        option type 'bridge'
        option stp '1'
        option igmp_snooping '1'
        option ipv6 '0'
        option bridge_empty '1'
        list ports 'eth1'
        list ports 'eth1.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.11'
        option netmask '255.255.0.0'
        list dns_search 'maduao.net'
        option delegate '0'
        option metric '1'
        option gateway '192.168.1.61'
        list dns '192.168.1.11'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '6t 2 3 4 5'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 1'
        option vid '2'

config device
        option name 'eth1'
        option ipv6 '0'

config device
        option name 'eth1.1'
        option type '8021q'
        option ifname 'eth1'
        option vid '1'
        option ipv6 '0'

config device
        option name 'phy0-ap0'

config device
        option name 'phy1-ap0'

config device
        option name 'phy1-ap1'

config device
        option name 'phy1-ap2'

config route
        option interface 'lan'
        option target '0.0.0.0/0'
        option gateway '192.168.1.4'
        option metric '100'

config device
        option name 'eth0'

config device
        option name 'eth0.2'
        option type '8021q'
        option ifname 'eth0'
        option vid '2'

# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option band '5g'
        option path 'pci0000:00/0000:00:00.0'
        option htmode 'VHT40'
        option country 'US'
        option cell_density '0'
        option channel 'auto'
        option txpower '24'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'HOME5G'
        option key 'UUUUUUUUUUUU'
        option encryption 'psk'
        option short_preamble '0'
        option macfilter 'allow'
        list maclist 'XXXXXXXXXXXXXXXXXX'
 
config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/ahb/18100000.wmac'
        option band '2g'
        option htmode 'HT20'
        option txpower '27'
        option cell_density '0'
        option channel '1'
        option country 'US'

config wifi-iface 'wifinet0'
        option device 'radio1'
        option mode 'ap'
        option ssid 'BRIDGEID'
        option network 'lan'
        option key '1'
        option encryption 'none'
        option hidden '1'
        option wds '1'

config wifi-iface 'wifinet1'
        option device 'radio1'
        option mode 'ap'
        option ssid 'HOME'
        option network 'lan'
        option key 'YYYYYYYY'
        option encryption 'psk'
        option macfilter 'allow'
        list maclist 'ZZZZZZZZZZZZZZZZ'

config wifi-iface 'wifinet3'
        option device 'radio1'
        option mode 'ap'
        option ssid 'PRINTER'
        option network 'lan'
        option key 'XXXXXXXX'
        option macfilter 'allow'
        list maclist 'XXXXXXXXXXXXXXXXX'
        option hidden '1'
        option encryption 'psk'
        option short_preamble '0'

# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option expandhosts '1'
        option authoritative '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option localservice '1'
        option ednspacket_max '1232'
        option local '/maduao.net/'
        option domain 'maduao.net'
        option filterwin2k '1'
        option cachesize '1000'
        option nohosts '1'
        list server '208.67.220.222'
        list server '209.244.0.4'
        list server '8.8.8.8'
        list server '8.8.4.4'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config host
    XXXX

config domain
    xxxx

# cat /etc/config/firewall

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config include
        option path '/etc/firewall.user'

config zone
        option name 'LAN'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'

I confirm, git of 23.05 from 2 weeks ago was working fine