Upgrading luci packages via opkg doesn't upgrade LuCI


I've just upgraded a router from OpenWRT "Chaos Calmer" to LEDE 17.01.4. After completing the upgrade I used opkg update and opkg list-upgradable, and it said there were a bunch of luci packages to upgrade:

luci-lib-ip - git-17.290.79498-d3f0685-1 - git-17.294.22464-0ed8086-1
luci-theme-bootstrap - git-17.290.79498-d3f0685-1 - git-17.294.22464-0ed8086-1
luci-app-firewall - git-17.290.79498-d3f0685-1 - git-17.294.22464-0ed8086-1
luci-proto-ppp - git-17.290.79498-d3f0685-1 - git-17.294.22464-0ed8086-1
luci-mod-admin-full - git-17.290.79498-d3f0685-1 - git-17.294.22464-0ed8086-1
luci-base - git-17.290.79498-d3f0685-1 - git-17.294.22464-0ed8086-1
luci-proto-ipv6 - git-17.290.79498-d3f0685-1 - git-17.294.22464-0ed8086-1
luci-lib-nixio - git-17.290.79498-d3f0685-1 - git-17.294.22464-0ed8086-1
luci-lib-jsonc - git-17.290.79498-d3f0685-1 - git-17.294.22464-0ed8086-1
luci - git-17.290.79498-d3f0685-1 - git-17.294.22464-0ed8086-1

I upgraded them, but after rebooting and logging in to LuCI it still shows the Git version as git-17.290.79498-d3f0685-1

I then tried removing LuCI altogether with opkg remove luci - but found that when I point a web browser to the router, LuCI is still there.

What am I doing wrong? Is this something to do with the fact that I upgraded from OpenWRT? or am I misunderstanding something?




From my LuCI GUI under the Software page:

luci git-17.291.49911-7fc88b4-1

From browsing to the router:

Powered by LuCI lede-17.01 branch (git-17.290.79498-d3f0685)

They don't match...and the same occurs on 3 other devices I've updated.

Can anyone else confirm this...and does anyone have ideas?

UPDATE: I failed to mentioned that I ran the upgrade to see the Krack vulnerability countermeasures for the station. So I can confirm that LuCI did update, it just shows the previous version number.

I can't reprocude even that.

I upgraded LuCI for luci-base and luci.mod-admin-full
from git-17.294.24601-59a4e40-1
to git-17.296.55856-3e00e13-1
and I see everywhere the correct info like:
Powered by LuCI Master (git-17.296.55856-3e00e13) / LEDE Reboot SNAPSHOT r5117-fbde9ac718
Firmware Version LEDE Reboot SNAPSHOT r5117-fbde9ac718 / LuCI Master (git-17.296.55856-3e00e13)
and the update software info for the two updated modules:

Remove 	luci-app-wol 	git-17.294.24601-59a4e40-1
Remove 	luci-base 	git-17.296.55856-3e00e13-1
Remove 	luci-lib-ip 	git-17.294.24601-59a4e40-1
Remove 	luci-lib-jsonc 	git-17.294.24601-59a4e40-1
Remove 	luci-lib-nixio 	git-17.294.24601-59a4e40-1
Remove 	luci-mod-admin-full 	git-17.296.55856-3e00e13-1

The version info is pretty much hard.coded into luci-base, so upgrading that should take care of the displayed version info.

I suspect a browser cache problem or something similar. (I use Firefox 57.0b10)

The commands that I ran:

  opkg list-upgradable | grep luci
  opkg upgrade luci-base
  opkg upgrade luci-mod-admin-full
  /etc/init.d/uhttpd restart
  rm -rf /tmp/luci*
1 Like

I've browsed from mutiple new browsers and devices. I've also cleared apps and the /home/foo/.mozilla/firefox folder, etc. The same issue persisted...

but...I think I discovered the problem...

I ran:

opkg update
opkg list-upgradeable
opkg upgrade foo

UPDATE TODAY: I'm currently upgrading from git-17.291.49911-7fc88b4-1 to git-17.296.55662-b74ef26-1

root@LEDE:~# opkg list-upgradable
luci-lib-ip - git-17.291.49911-7fc88b4-1 - git-17.296.55662-b74ef26-1
luci-theme-bootstrap - git-17.291.49911-7fc88b4-1 - git-17.296.55662-b74ef26-1
luci-app-firewall - git-17.291.49911-7fc88b4-1 - git-17.296.55662-b74ef26-1
luci-proto-ppp - git-17.291.49911-7fc88b4-1 - git-17.296.55662-b74ef26-1
luci-mod-admin-full - git-17.291.49911-7fc88b4-1 - git-17.296.55662-b74ef26-1
luci-base - git-17.291.49911-7fc88b4-1 - git-17.296.55662-b74ef26-1
luci-proto-ipv6 - git-17.291.49911-7fc88b4-1 - git-17.296.55662-b74ef26-1
luci-lib-nixio - git-17.291.49911-7fc88b4-1 - git-17.296.55662-b74ef26-1
luci-lib-jsonc - git-17.291.49911-7fc88b4-1 - git-17.296.55662-b74ef26-1
luci - git-17.291.49911-7fc88b4-1 - git-17.296.55662-b74ef26-1

On browser before upgrade:

Powered by LuCI lede-17.01 branch (git-17.290.79498-d3f0685)


Powered by LuCI lede-17.01 branch (git-17.290.79498-d3f0685)

in the software list:



Powered by LuCI lede-17.01 branch (git-17.296.55662-b74ef26)

Andy, please see if a reboot of the device after upgrade solves your issue.

1 Like

Very informative thread. I too got the same after updating the luci packages (ie the reboot was required to see the new message).

This is LuCI's internal byte code caching. Try running "rm -r /tmp/luci-modulecache/" to force it to recompile the version file.

1 Like

That did the trick on today's update to git-17.298.45605-07e7ff0

Thanks all for your help, and sorry for the delay in replying - I've been away for a few days.
Clearing the byte code cache followed by a reboot solved the problem - thanks jow and lleachii.



This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.