Upgrading from 18.06.0-rc1 ( Raspberry Pi)

Is there a guide on upgrading from 18.06.0-rc1 to the release version?

It's the same version, you just flash it. What instructions are you seeking?

I thought there might be something like a 'opkg upgrade' command...

In all cases of flashing, you must reinstall packages not included in the firmware.

opkg update
opkg install foo

The kernel was updated between -rc1 and final, you need to sysupgrade (keeping settings is fine).

1 Like

Do you mean I need to run 'sysupgrade' at command prompt?

dwl firmware for your device to pc
Luci->System->backup/flash firmaware
then browse
then flash

Note: you can keep your current settings by marking the checkbox


also good idea to backup your settings from the same page first for referernce

1 Like

On a Raspberry Pi do I just copy
to a USB stick and select that from
Luci->System->Backup/Flash Firmware ?

Are you asking because sysupgrade didn't work?
It helps if you provide context to your questions, it just seems as if you haven't tried to flash yet.
Feel free to use the WIki for things like this.

cd /tmp
wget http://downloads.openwrt.org/snapshots/targets/foo/foo/foo.img.gz
sysupgrade -c foo.img.gz

(But I assume that you already tried sysupgrade via SSH and LuCI.)

IF THAT DOESN'T WORK (because it's an IMG file compressed):

You could:

  • Backup your files in LuCI (as normal)
  • Redo the flash (i.e. when you first installed OpenWrt on the device)
  • Reinstall your configs from the backup file via LuCI (as normal)

Thanks for the pointer. I haven't tried yet as I wasn't sure if should extract something from the archive. I have a couple of systems to upgrade. Thanks for the command line - I'm not a big fan of GUIs. Presumably 'sysupgrade -c foo.img.gz' also works on PCs (assuming the relevant foo.img.gz of course).

Trying the GUI I get:-

The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.

Do I need to extract it first?

I'm using openwrt-18.06.0-brcm2708-bcm2709-rpi-2-ext4-factory.img.gz

As I noted:


root@OpenWrt:/# sysupgrade -i --test /mnt/openwrt-18.06.0-brcm2708-bcm2709-rpi-2-ext4-factory.img 
Image not in /tmp, copying...
Image metadata not found
Use sysupgrade -F to override this check when downgrading or flashing to vendor firmware
Image check 'fwtool_check_image' failed.

Does this sound like I have the wrong image?

No...I've mentioned 2 times:


I understand the point about if it doesn't work, but I'm trying to find out why it doesn't work

When I get a msg like

Image check 'fwtool_check_image' failed.

I want to know why it failed and if it's something I've done wrong.

Sysupgrade process depends on the target & device to some extent. Most routers have a straightforward sysupgrade process, but Raspberrys may need other steps, as they use different bootloaders and flash type (memory cards) than "normal" routers. lleachii gives above one way to perform upgrading.

I edited the topic title to mention Raspberry, as that is the key here. Hopefully some Raspberry specialist can give you more details.

This is the important bit. I think the suggestion here is YOU CAN NOT UPGRADE so what you need to do is backup your settings first and keep them some where safe on your PC if you want to keep them
Then format your SD card and Install a new OpenWRT like you did the first time you installed OpenWRT. That is start again with a fresh install DO NOT UPGRADE.
Then you can use your backup to restore you previous settings or just redo everything manually.

1 Like

The question then is: Why do we have sysupgrade images for RPi in the first place?

1 Like

@lleachii in the wiki is mentioned a file 'openwrt-brcm2708-bcm2708-sdcard-vfat-ext4.img' which is no longer available with latest 18.06 version, as a result how do you redo the initial installation ?