Upgraded to 21.02: missing packages

I just upgraded my HH BT5 to openWRT v.21.02. I noticed that some packages are not available:
libustream-openssl luci-ssl-openssl transmission-daemon-openssl transmission-remote-openssl
Do I still need them since openWRT v.21.02 comes with embedded SSL?
Moreover, wireguard is not present any more, but it is available kmod-wireguard. It is enough?
Thank you

Wireguard is now integrated into the kernel, so the old kmod-wireguard is no longer necessary.

TLS/SSL is already included. So unless you specifically need a different openssl version, you don't need to install that, either.


Thank you. I though that wireguard was integrated into linux kernel v.5.6+ only while openWRT v.21.02 uses linux kernel v.5.4.

Release notes can be found here

  • wireguard backport from upstream Linux kernel
1 Like

kmod-wireguard stills exists in 21.02 and is needed. (We are just not using a separate proprietary version of the out-of-tree source code, but instead the source is backported from the Linux kernel repo from newer Linux versions. And even in future (after 5.10), kmod-wireguard will remain there.)

You are likely seeing a bug related to cgi-io, used in LuCI for dependency parsing.

Should be already fixed, just opkg upgrade cgi-io.

opkg update
opkg upgrade cgi-io
1 Like

Really? I did not install it on my system (unless it was installed when I installed luci-app-wireguard), and Wireguard is working perfectly for me. Did I misunderstand or not notice something?

EDIT: I do see it installed when I run opkg list-installed | grep wireguard, but it must have been installed as a dependency. For some reason, I thought it was included in the base system.

thank you. I upgraded cgi-io, but the previous packages are still not available libustream-openssl luci-ssl-openssl transmission-daemon-openssl transmission-remote-openssl

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.