Upgraded to 18.06.5 and radios stopped working

I have a Netgear 3700v4 that I've been running 18.06.4 on without problems. Upgrading to 18.06.5 left me with non-functional radios. Both the 2.4 and 5 Ghz radios are show up in LUCI, but show no statistics and "not assiciated" (from memory) where the statistics should be. The blue leds indicating the radio is working are off too. I checked each of the available LUCI pages to see if anything jumped out at me. I tried rebooting in case it was like the old initial upgrade problem with 5Ghz radios where you needed to power cycle after upgrade to shake the radio loose. Rebooting didn't help. Nothing looked fishy. All the radio settings looked just like I had set them under the previous 18.06.4.

I reverted back to 18.06.4. The radios still didn't work. Is there some state that is saved in a config file or elsewhere I need to revert?

Stupid question perhaps but did you reset to factory settings?

I did clear the user settings from LUCI but that wiped all of the settings and apps including LUCI. I'm still in the process of getting the basic stuff like LUCI back. What is the best way to reload from a backup file? Is there a command line command or do I just "cd / ; tar -xvf /tmp/backup..."

System>backup/flash firmware is there you create and restore backups. You can also preform a reset which is what I was suggesting.

The default setting for Wifi is to be off. Did you check if radios are disabled indeed?
What is the output of wifi status ; wifi up ; wifi status ?

BusyBox v1.28.4 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 18.06.4, r7808-ef686b7292
 -----------------------------------------------------
[root@ap ~]# wifi status ; wifi up ; wifi status
{
	"radio0": {
		"up": false,
		"pending": false,
		"autostart": true,
		"disabled": false,
		"retry_setup_failed": true,
		"config": {
			"hwmode": "11g",
			"path": "platform\/ar934x_wmac",
			"htmode": "HT20",
			"country": "US",
			"legacy_rates": true,
			"channel": "auto"
		},
		"interfaces": [
			{
				"section": "default_radio0",
				"config": {
					"mode": "ap",
					"ssid": "wsrcc",
					"encryption": "psk2+ccmp",
					"key": "<redacted>",
					"ieee80211w": 1,
					"network": [
						"lan"
					],
					"mode": "ap"
				}
			}
		]
	},
	"radio1": {
		"up": false,
		"pending": false,
		"autostart": true,
		"disabled": false,
		"retry_setup_failed": true,
		"config": {
			"hwmode": "11a",
			"path": "pci0000:00\/0000:00:00.0",
			"country": "US",
			"legacy_rates": true,
			"channel": "auto",
			"htmode": "HT40"
		},
		"interfaces": [
			{
				"section": "default_radio1",
				"config": {
					"mode": "ap",
					"ssid": "wsrcc5",
					"encryption": "psk2+ccmp",
					"key": "<redacted>",
					"ieee80211w": 1,
					"network": [
						"lan"
					],
					"mode": "ap"
				}
			}
		]
	}
}
{
	"radio0": {
		"up": false,
		"pending": true,
		"autostart": true,
		"disabled": false,
		"retry_setup_failed": false,
		"config": {
			"hwmode": "11g",
			"path": "platform\/ar934x_wmac",
			"htmode": "HT20",
			"country": "US",
			"legacy_rates": true,
			"channel": "auto"
		},
		"interfaces": [
			{
				"section": "default_radio0",
				"config": {
					"mode": "ap",
					"ssid": "wsrcc",
					"encryption": "psk2+ccmp",
					"key": "<redacted>",
					"ieee80211w": 1,
					"network": [
						"lan"
					],
					"mode": "ap"
				}
			}
		]
	},
	"radio1": {
		"up": false,
		"pending": true,
		"autostart": true,
		"disabled": false,
		"retry_setup_failed": false,
		"config": {
			"hwmode": "11a",
			"path": "pci0000:00\/0000:00:00.0",
			"country": "US",
			"legacy_rates": true,
			"channel": "auto",
			"htmode": "HT40"
		},
		"interfaces": [
			{
				"section": "default_radio1",
				"config": {
					"mode": "ap",
					"ssid": "wsrcc5",
					"encryption": "psk2+ccmp",
					"key": "<redacted>",
					"ieee80211w": 1,
					"network": [
						"lan"
					],
					"mode": "ap"
				}
			}
		]
	}
}

I reset and then loaded the backup I took just before upgrading to 18.06.5. I'm back on 18.06.4 and the radios both still don't work. Wifi status in the previous post.

They are disabled and don't come up.

Erase wifi config and let the router recreate it. Then go ahead and enable/reconfigure

rm /etc/config/wireless ; wifi detect

Thanks. That was the key. "wifi detect" came up with a gripe to use "wifi config" which I did. I intentionally did a minimal config where I only changed the SID, encryption and cipher before enabling. Here is a diff of my pre-reconfig wireless with the current working one.

diff -u wireless-save wireless
--- wireless-save	2019-11-13 21:24:26.000000000 -0800
+++ wireless	2019-11-14 02:27:51.000000000 -0800
@@ -1,12 +1,12 @@
 
 config wifi-device 'radio0'
 	option type 'mac80211'
+	option channel '11'
 	option hwmode '11g'
 	option path 'platform/ar934x_wmac'
 	option htmode 'HT20'
 	option country 'US'
 	option legacy_rates '1'
-	option channel 'auto'
 
 config wifi-iface 'default_radio0'
 	option device 'radio0'
@@ -15,16 +15,15 @@
 	option ssid 'wsrcc'
 	option encryption 'psk2+ccmp'
 	option key '4323667960781137'
-	option ieee80211w '1'
 
 config wifi-device 'radio1'
 	option type 'mac80211'
+	option channel '36'
 	option hwmode '11a'
 	option path 'pci0000:00/0000:00:00.0'
+	option htmode 'HT20'
 	option country 'US'
 	option legacy_rates '1'
-	option channel 'auto'
-	option htmode 'HT40'
 
 config wifi-iface 'default_radio1'
 	option device 'radio1'
@@ -33,5 +32,4 @@
 	option ssid 'wsrcc5'
 	option encryption 'psk2+ccmp'
 	option key '4323667960781137'
-	option ieee80211w '1'
 

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.