Upgraded from 17.01.4, but now there is no internet receiving

Belkin AC1750DB

It shows that the ipv4 upstream does not have connectivity, do I need to do something here? It has simply worked before but this time it gets no internet.


19days uptime

Maybe it just needs a reboot

I gave up on it 19 days ago, its been on default settings, and connected to an older slower router. There is internet working, just not on the openwrt belkin.

Under network ipv4 upstream it should show connected right?

If have connected the WAN and your WAN settings are correct.

Have checked your settings and connection.

If your not sure, reset the settings using the system menu and start from the beginning.

I have done a reset and I have also tried a backup from previous settings, neither work. With a vanilla install is there something I need to do to the wan settings?

like i said it has always worked with default settings in the past. I've never had to make changes to the wan, or bridge any ports.

Not sure what to suggest apart from general troubleshooting which you may have already tried.

  • Check System Logs (logread)
  • Check Kernel Logs (dmesg)
  • Check Cables ( and any Leds on ports)
  • Power Cycle Router and Modem
  • Check/Confirm MAC address of WAN

Does it work with the original firmware or OpenWrt 17? Do all the other ports work? Maybe the default wan port is broken. Does it send/receive any data? You could try using one of the lan ports as wan.

1 Like

I upgraded from 17.01.4, and it immediately had this problem. I assume the port still works. How would I downgrade back to that version?

So this is odd. Resetting to default settings did not help, i tried port 1 instead of the wan port for internet and still no luck. But.. when I loaded up my old backup from the lede 17.01.4 it works! *on port 1.

Problem is now I am unable to access luci interface from

So it works, minus a port and luci.

Also prior to this, it did see the wan port and that there was a cable connected just nothing would work.

My guess is there is a security setting that prevents luci access via this new port?

So I have luci over wifi, but wifi does not have internet. Haha.

Okay, maybe I used the wrong update file?

Filename: openwrt-18.06.1-ar71xx-generic-f9k1115v2-squashfs-sysupgrade

As mbo2o said, have you checked the logs? Do you keep settings when you upgrade? If so then don't, especially if you're downgrading. There is a v17.01.6 you can try too. It contains more security fixes than .4. Make sure you do a software reboot after you change any settings. Don't restart it by pulling the plug. Have you checked that Wan uses the correct protocol when it tries to connect? Does the router you're trying to get an IP from also use the address on the internal network?

Normally yes, the other router would use the same ip but in this case it was connected directly to the cable modem. As far as I can tell no settings were carried over. Except those that I backed up and then applied. When I did a reset, nothing worked. When I ran the backup connected directly to the modem it worked via ethernet but no access to luci. (port 1 not the wan) And while using wifi it allowed me access to luci but the console then shows everything is down and offers no internet through wifi. It is complete bonkers, which is why I asked if I maybe used the wrong update file. The update page mentions two different files. I'd just download the other file and try it but do not want to risk bricking it.

Is there a way to downgrade to my previous version? "17.01.4"

Or downgrade to the manufacturer original firmware?

If you can connect using ssh or luci you can install a previous sysupgrade version like you would with a newer version. Don't keep settings.