Upgraded a year old openwrt install with sysupgrade. Can ssh into router with password, won’t work via LuCI login

Hello,
I Upgraded a year old openwrt install with sysupgrade.
I Can ssh into the router with ‘root’, ‘my password’ without trouble.

Trying to check settings via LuCI, but luci refuses login.
Is there a way to reset the luci password?

I’d fix it tomorrow, but there is no internet access of anything Internet via the router.

I guess I’ll try to figure out how to restore the old firmware via ssh for now.

Would like to be able to keep the old settings, tried printing them all and downloaded them.

Thanks for your time,
Bobby

the luci password is the same as ssh...
root / ...

Luci is just goes back to the login page no matter how many times I attempt a login.

Repeated the following a few times in various incarnations ...

Via putty set a passwd
Login in a second putty session to verify

Via winscp uploaded the sysupgrade.bin to /tmp

Did a sysupgrade -v -n /tmp/*.bin

Did a firstboot -y && reboot now

Luci no like login for me.

How do I get the *.factory.bin to flash? Via cli on putty?

Added hard factory reset
umount /overlay && jffs2reset && reboot now

Will see if that helps

And that finally worked

Sorry for the distraction

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.