Upgrade Turris Omnia 2020 to OpenWrt 21.02

Hello !
Please tell me exactly how can I upgrade my Turris Omnia 2020 to OpenWrt 21.02.

I tried everything without any success.

I prefer to upgrade to OpenWrt using Turris Omnia web interface but I did not found it...

I tried with :

cd /tmp
wget http://downloads.openwrt.org/path/to/sysupgradeimage
sysupgrade /tmp/xxx.abc

But I get an error :
root@turris:~# sysupgrade
-ash: sysupgrade: not found

I tried with :

LuCI Web Upgrade Process

  • Browse to % LuCI Upgrade URL

  • Upload image file for sysupgrade to LuCI

  • Wait for reboot

but I also get an error :

404 Not Found

Sorry, the object you requested was not found.

Unable to dispatch: /cgi-bin/luci/mini/system/upgrade/%Powered by LuCI branch (git-22.025.78315-f3debdc) / TurrisOS 5.3.5 524cbcf6f5b07f3d9ee45e445da12760947e232e r11397+89-524cbcf6f5I tried with 5 led reset :

  1. Download openwrt-*-sysupgrade.img.gz, gunzip it, and copy the resulting .img file to the root of a USB flash drive formatted with FAT32 or ext2/3/4.

  2. Enter a rescue shell: Either via 5-LED reset and ssh root@ on LAN port 4, or via 7-LED reset and the serial console.

  3. Insert the USB drive and mount it: mkdir /mnt; mount /dev/sda1 /mnt.

  4. Flash the OpenWrt image to eMMC: dd if=/mnt/openwrt-*-sysupgrade.img of=/dev/mmcblk0 bs=4096 conv=fsync.

  5. reboot.

and I always get an error telling me that drive is busy or not found...

What can I do ?

Thank You Very Much !

Maybe vai tftp method if you have a serial

HTTP doesn't work on the downloads site...use HTTPS.

You usually don't flash a sysupgrade image directly to a chip. Is there a factory image?

:spiral_notepad: You can also scp the file to the /tmp folder from your computer.

Maybe you should start first by reading the documentation, either OpenWrt or Turris. There is everything what are you looking for. :wink:

Can you be more specific, please ?
I did read the documentation from OpenWrt...

I downloaded https://downloads.openwrt.org/releases/21.02.2/targets/mvebu/cortexa9/openwrt-21.02.2-mvebu-cortexa9-cznic_turris-omnia-sysupgrade.img.gz and copied the downloaded file to Turris Omnia router's /TMP folder with WINSCP.
I can connect to router with putty.
But when I try to run sysupgrade /tmp/openwrt-21.02.2-mvebu-cortexa9-cznic_turris-omnia-sysupgrade.img.gz, I get the error :
-ash: sysupgrade: not found

Which file should I download from OpenWrt ?
I don't know what to do...

Thank You !

Is your router currently running OpenWrt?

Yes, you should check the whole article. For example, you should start with:

  1. Determine U-Boot version
  2. Installation with U-Boot 2019.07 or later

Of course, what you are doing is not going to work as in Turris OS there is a removed sysupgrade for its reasons, right. There is Updater-ng, which takes care of Updates.