Upgrade silently fails via Luci flash and sysupgrade -v on Netgear R8000

I'm currently on 19.07.03, trying to upgrade to 19.07.05. I've tried flashing via luci probably six times now, both with and without saving settings. I've also tried logging in via SSH and using sysupgrade -v with no luck. Last I tried using sysupgrade -i and when prompted to save settings I selected no. Each time, it appears flashing starts working, only to see that it's still on version .03 after reboot.

root@HomeRouter:~# cat /etc/openwrt_release
DISTRIB_DESCRIPTION='OpenWrt 19.07.3 r11063-85e04e9f46'

I found a way to get 19.07.05 installed but it isn't ideal. I had to run firstboot and then reboot -f. I was then able to scp the image to the router and use sysupgarde to install. Of course there were no settings so I had to reconfigure everything.

This solution leads me to believe there is a shortage of free memory that causes the upgrade to silently fail.

I have a backup R8000 that I'll upgrade in a few days if 19.07.05 seems solid.