Upgrade Pogoplug Mobile (or Series 4) from OpenWrt to LEDE

Ok new developments, after trying so many things I can't even tell what actually fixed it, It is booting debian now and of course I'll be able to reinstall openwrt back to nand.
All I know is that it had to do with envs
I guess I'm gonna have to learn more about this if I want to continue tinkering with pogo in the future.
Thanks to everyone who help me...
You'all have a very happy 2018

@bitcom Yes, the uboot envs should be correct in order to boot properly probably it was just that. The thing that if you set env using serial to uboot you should run saveenv to write it into eprom.

if you documented the steps please post it here too, at least a briefing.
So doing a summary, you upgraded to newer uboot? how? and later you tried to sysupgrade using the Pogo_e02 tar.gz right?
You did boot properly to LEDE but you didn't have mtd-utils and since you didn't be able to boot to Debian you couldn't continue, right?

Sorry but I want to fully understand the problem in order to try later by myself too, in case that we can have success on this and elaborate a easy to follow instructions to upgrade from OpenWrt to LEDE. Since @markbirss says that those steps worked fine for him on their PogoPlug Series 4 probably it should work for PogoPlug Mobile. more info: http://blog.qnology.com/p/difference-between-pogoplug-mobile-and.html

@bitcom did you upgrade your uboot as required in the "https://forum.doozan.com/read.php?4,42279,42279" guide ?

if you are able to boot lede from initramfs then you should be able to install Lede on nand ?
lede dont need mtd-utils the nand is erased in uboot with nand erase.part ubi and then sysupgrade installs to the nand

did you follow that doozan.com post?
does it work on pogoplug mobile 4?
i have unmodified pogoplug m4 but these instructions do not work, do i need first install doozan.com debian on usb drive and then follow that post?
please somebody help, could not find clear step by step instructions on how to install lede on pogoplug mobile 4 internal flash memory. wiki makes no sense.
some posts are saying you have to "ubinize" lede, wtf is "ubinize"?

A quick Google search shows that ubinize is a tool for generating UBI images...

http://manpages.ubuntu.com/manpages/zesty/man8/ubinize.8.html

Guys, if you need OpenWRT you could try the same steps that I follow, see: Upgrade Pogoplug Mobile (or Series 4) from OpenWrt to LEDE

If you want LEDE too but you could wait there will be official support soon on next release, don't know how, but at least there is a PR on sources in order to have image ready soon. You can also ask to Alberto @bobafetthotmail to see if he could sumbit their image somewhere with steps on how to use it in order to try some of us on our devices too.

https://github.com/openwrt/openwrt/pull/592#issuecomment-355412631

yes, i followed https://forum.doozan.com/read.php?4,42279,42279 guide.

what does not make sense ?

you need serial console and latest uboot

The PR was merged, now there is official support for pogoplug v4 in LEDE/newOpenwrt. See the install instructions in the PR https://github.com/openwrt/openwrt/commit/c19f811c4d732f634ac18f33ae95e954ac9e8c81

The images are in the development snapshot now https://downloads.lede-project.org/snapshots/targets/kirkwood/generic/ (the usual limitations of the snapshot or OpenWRT trunk applies, there is no web interface by default and installing drivers will not work after a few days when the kernel was updated in the newer snapshot. It's better if you use the Image Builder to create a firmware with all packages you need already integrated)

It will work also for upgrading from older OpenWRT. Using stock uboot and second stage uboot is not supported, you will have to replace the uboot.

For those using other uboots, here is the LEDE/newOpenWRT uboot configuration, so you can adjust yours. It is possible to make your device boot first Debian or Arch or whatever from USB/Sata/SDcard and if that fails try to boot OpenWRT/LEDE from internal flash.
Just look at the current bootcommand, I chained first an USB boot for the recovery feature, and if that fails the uboot will do the boot from LEDE/OpenWRT.
You will just need to add your bootcommand's lines before mine and it will first try booting your stuff, then if it fails it will try the next, and eventually boot from onboard flash memory where LEDE/Openwrt is.

You need a uboot that supports nand and ubi commands, and to use the "recovery" feature it must support also usb commands (to load the image from USB). Bodhi's uboot supports these things already.

bootcommand=usb reset ; fatload usb 0:1 0x2000000 initramfs.bin bootm 0x2000000 ; setenv bootargs='' ; ubi part ubi; ubi read 0x800000 kernel; bootm 0x800000
mtdparts=mtdparts=orion_nand:0x1c0000(uboot),0x40000(uboot_env),0x7e00000(ubi)
mtdids=nand0=orion_nand

@markbirss

tried to install as advised newest 2017.07 uboot by bodhi on unmodified Pogoplug v4, so went to forum for uboot howto installation and this does not make sense:
"Note: for boxes such as Pogo V4 and Zyxel NSA3xx, the mtd partition definition are kept the same as stock definition, therefore is different from the one above. "
Ok different but bodhi makes references to different partition layout and have no idea how to adapt his instructions:

https://forum.doozan.com/read.php?3,12381

@bobafetthotmail

thank you for trying to help but can you tell what PR is? Where is file u-boot.kwb?
I am now lost which uboot should I install? Bodhi or yours?
Ideally I am looking for simple, clear instructions like here:

https://archlinuxarm.org/platforms/armv5/pogoplug-series-4

I would like to install original LEDE firmware from here:

https://downloads.lede-project.org/releases/17.01.4/targets/kirkwood/generic/

On wiki they say to use Pogo E02 firmware on Pogo v4:

https://lede-project.org/toh/hwdata/pogoplug/pogoplug_pogoplugmobilev4

Is wiki correct?

My understanding I should install uboot 2017.07 by bodhi and this new uboot will let me flash LEDE firmware from USB stick. Is this correct?

A PR is a PullRequest on github, is a petition to merge new code into the main codebase.

here are some comments about this: Lede on Pogoplug Pro, Bad Magic Number

I think that is not necessary to upgrade uboot, just change uboot config to boot properly, it seems that there is a way to config uboot to point to a newer uboot and config that too... (seen on that forum thread), My notes worked perfectly for OpenWrt 15.05.1, and the @bobafetthotmail worked for him using LEDE 17.01.4, I've not tried yet because of lack of complete instructions to test, and I had no time these days for compile it by myself neither, also, I never compile, the first time I've tried it takes so long, so I always build my images using precompiled packages. So I think I will wait until a proper step by step guide on how to upgrade from OpenWrt 15 to Lede 17, or for a new OpenWrt 18...

Pull request. It is a way to contribute code to LEDE/OpenWRT. I contributed support for Pogoplug v4 and an uboot based on Bodhi's uboot source code.

It is in the "u-boot-pogoplugv4" under the "Supplementary files" table from here (snapshot download page)
https://downloads.lede-project.org/snapshots/targets/kirkwood/generic/

the LEDE/Openwrt one is already configured to boot LEDE/OpenWRT.

Bodhi's uboot is not configured to boot from internal flash memory but it can do so. You just need to change its text configuration, this can be done easily if you have serial console attached to the device.

I can help you with this, answer the questions I ask below so I know what device you have.

The first link should have shown my contribution to LEDE/OpenWRT (LEDE is now merged back and will be called OpenWRT again) where I have written install instructions https://github.com/openwrt/openwrt/commit/c19f811c4d732f634ac18f33ae95e954ac9e8c81 but currently the whole github site seems to be down.
EDIT: now it is back up again.

Wait and please answer my questions first as there are two versions of Pogoplug v4, see below.

That is the link for LEDE stable release. New devices are not added to an older LEDE stable release. Pogoplug v4 (the full featured one) will surely be in next stable release.

Yes, that's the Pogoplug v4 with less features.
The device I added is the Pogoplug v4 with full features, my one has a Sata slot (on top) and USB 3.0 ports on the back. This is its page https://lede-project.org/toh/hwdata/pogoplug/pogoplug_pogoplug_v4

Please tell me what device you have, does it have usb 2.0 ports (black) or 3.0 USB ports (blue) on the back? Sata port on top?

What you did to your device before I posted here? Did you already install bodhi's uboot or your device is still on stock uboot and firmware?

Do you have serial console attached?

If you answer these questions I can write down instructions you can follow to install LEDE in it.

Yes, bodhi's uboot will allow you to load and install from USB stick, but you must use serial console to tell it to do it.

1 Like

OK, what does

cat /proc/mtd

show?

@bobafetthotmail

>Please tell me what device you have, does it have usb 2.0 ports (black) or 3.0 USB ports (blue) on the back? Sata port on top?

I have POGO-V4-A1-01, one with blue logo on front, it has no SATA, no USB 3.0. It has only one USB 2.0 and one SD Card slot. Mine is called Pogoplug Mobile, you have newer version Pogoplug V4 with SATA. Sorry about confusion.

>What you did to your device before I posted here? Did you already install bodhi’s uboot or your device is still on stock uboot and firmware?
Do you have serial console attached?

My Pogoplug is still in factory condition it has 3.2 firmware installed, I taped serial cable to get SSH access but it fell off. Over weekend I will try to solder wires and reenable SSH. I believe my device is the same LWL user has:
https://forum.doozan.com/read.php?3,47594

except mine is on 3.2 firmware, it will not update to 3.4 as his did, probably because CloudEngines turned off its services.

Thanks again for your help, if you can write instructions for different device that is great otherwise please bear with me and I will report back on my progress.

my pogo v4 has the 2 usb 3 ports and sata

it this fully supported with your build ?

See this OpenWrt article for a full explanation...

https://wiki.openwrt.org/doc/techref/flash.layout#mtd_memory_technology_device

@jwoods no this was meant for @terme to actually run and share the output

Now @terme will have a full explanation of MTD...:wink:

Yes, that is the device I have added support for.

1 Like