Upgrade Pogoplug Mobile (or Series 4) from OpenWrt to LEDE

Hi braian87b

I looked into this and found a git repo for the Pogo Series 4 LEDE

you have to build LEDE for the Pogoplug V4 and also select tar.gz output image
then find the zImage files and follow same instructions as getting OpenWrt onto the internal flash

I will try to build LEDE using that repo again.
once I got the tar.gz, how can I upgrade, I didn't catch that part yet, I don't know how to update it.

normal sysupgrade command will work?


Hi everybody.
I too have one of this units that I need to convert to openwrt, for a squeezelite player with usb sound card so I need to boot fro SD card,
my problem is I build from that repo but the box freezes after starting the kernel, I tried going to gzip compression in kernel _menuconfig to no avail, same thing.
anybody has a suggestion?

Follow carefully the steps on: http://blog.qnology.com/2015/02/openwrt-on-pogoplug-mobile.html

You should install first Debian and then you will be able to install OpenWRT on the 128mb flash (no need of SD card).

Currently my pogo's works extremely well with OpenWRT, we will have to wait until further release, latest lede is 17.01.4 and does not have release of pogo v4, but currently devs are migrating all code again to OpenWRT so probably 17.01.5 or 17.02.x or 18.x.x will have pogo v4 support again.

If you are adventorous and want to try to build the .tar.gz by yourself please post your findings here.

If you were able to boot to OpenWRT and boot to Debian when you insert an SD card, let me know, I don't remember but I think I wanted that but does not work if I remember correctly., I don't know.

Note: With Debian the pogo works very well too.

Only downside of this hw is that is a little slow to use as NAS (tipical primary intended use)


Yes sysupgrade with the tar file (refer below)

Im running the Pogoplug E02 build now instead on my Pogoplug Series 4 (cpu
run slower and less ram)

Here are instructions



Hi brian and thanks for the link, I've been there the problem is all the download links are now dead so it's not possible to follow those inst.
On the other hand I'm already running debian jessie on it but as you know it's a lot slower and prone to SD failure as I have a lot of power failures.
I build lede from this guys repo: https://github.com/nwf/lede
He has added the pogo v4 and builds all kinds of images but they all fail with the: starting kernel freeze problem.
I also build openwrt CC which boots the kernel well but it fails to find the rootfs on mmcblk0p1 which is there formatted as ext3, this is the error.
VFS: Cannot open root device "mmcblk0p1" or unknown-block(0,0): error -6
So I guess I'm out of luck

It works the same? no problems at all? it is possible to upgrade current OpenWRT that I have to the pogo E02 image ? how? Thanks!

try this, worked fine for me:
instead of:

wget http://downloads.openwrt.org/chaos_calmer/15.05/kirkwood/generic/openwrt-15.05-kirkwood-generic-rootfs.tar.gz
wget http://downloads.openwrt.org/chaos_calmer/15.05/kirkwood/generic/openwrt-15.05-kirkwood-zImage   
wget http://downloads.openwrt.org/chaos_calmer/15.05/kirkwood/generic/md5sums

use these ones:


instead of downloading this: http://download.qnology.com/pogoplug/v4/fw_setenv
you sholud do apt-get install u-boot-tools

instead of:

wget http://download.qnology.com/pogoplug/v4/fw_printenv
wget http://download.qnology.com/pogoplug/v4/fw_setenv
wget http://download.qnology.com/pogoplug/v4/ubiattach
wget http://download.qnology.com/pogoplug/v4/ubimkvol
wget http://download.qnology.com/pogoplug/v4/ubiformat

you should do apt-get install mtd-utils

about kirkwood-pogoplug_v4.dtb use the one inside Debian:

cd boot
cp /boot/dts/kirkwood-pogoplug_v4.dtb ./kirkwood-pogoplug_v4.dtb

check out my notes about: https://gist.github.com/braian87b/2f7e711ebdd48e7a7d37f286e5245b0d
If you need more help, let me know.

And if you can check if you can do extroot of OpenWRT to SD or USB let me know, I've tried some months ago but it didn't work: https://gist.github.com/braian87b/7a50f5634b6b39748cf72d42ff7d4476

Great thanks alot for your help, I did that but somehow I ended up with only 2 partition not 3 this is what I have:
0: u-boot 0x00100000 0x00000000 0
1: rootfs 0x07f00000 0x00100000 0
instead of:
#mtd0: 00100000 00020000 "u-boot"
#mtd1: 07f00000 00020000 "rootfs"
#mtd2: 00010000 00008000 "spi0.0"
I follow the instructions on qui's blog but did not work.
I'll read your notes
thanks again

it looks all ok, usb3 ports not working as b4

im using usb wifi adapter

not sure if sysupgrade will work from openwrt

Hello again Braian, I can't thank you anough for your help.
Those instructions really worked great.
Finallly after 3 days of grief, I was able to boot openwrt on this pogo.
Thank you soo much and have a very Happy new year 2018

Good! I will try it then when I have spare time!

Yes, there are a known problem with USB3, since mine is PogoPlug Mobile it has one USB2 only, but I remember read somewhere that there is a way to solve the usb3 problem. Edit: I found it:

Some people tell me that sysupgrade will work If you use the .tar.gz but I did'n tried it yet.
I think that will be safe to try to sysupgrade to 15.05 and then go back to 15.05.1 again.
And If something goes wrong just keep around SD with Debian too boot it again.

Currently there is no build on LEDE, but I found on github a forked repo that have support (didn't tried it yet), and I'm trying to request a pull on the main repository in order to get it on next release of OpenWrt (LEDE changed name again to OpenWrt)

I've suffered many times asking for help and people telling me "man [that shit]" or "RTFM" or "Google it", or even giving me steps like I already know how to do it but forgotten the order. That is not fair and that is because I always try to help in the best manner possible, although I already know that them are trying to help in some way, sometimes is frustrating.

You're welcome!, and Happy new year for you too!

And please if you find something useful post it here in the Forum.

Ok, let me know how yours working once you put the E02 build

Hey guys, I'm back with bad news.
I was also trying to do a sysupgrade because I need this unit as squeezelite player so I have my own build image, so I followed this guide:
which supposed does just that, I did everything by the guide but ended up again with a brick, now I can't even boot debian on usb like before.
But that's ok I know I can bring it back as long as uboot is there wright?

I don't know much yet about Pogo, but I've unbricked several times some Tp-Link routers, Will try to help you.
Start with finding Serial-TTL pins on board

, solder the 4 cables, but you probably just need the GND+RX+TX (VCC usually should not be connected) and get a USB Serial TTL cable from somewhere, with that cable you should see some boot log, post it here, and try to run help or something to see available commands too.

The important ones are marked as 2 and 3, the 1 is VCC it's does not needed, and 4 is GND, is all around (probably for this japanese guy was more easier to solder over the other pad, actually when I solder it I did the same)

Edit: If you dont have USB Serial TTL you could try to use a RaspberryPi or similar board with 3.3volt UART, and use minicom on ssh from your computer. I did that once and worked fine.

Ok some progress I have serial console, and I'm able to boot initramfs image from the above guide.
Problem is on lede I don't have access to mtd-utils to do the original process again.
Yes me too I have done debrick of many routers before but as we have found the hard way this pogo thing it's a totally different animal.

you had Debian running ? if not prepare an SD with it an put it and do it using that.
then try: apt-get update; apt-get install mtd-utils

Yes debian run good before I did the sysupgrade stuff.
but it seems my args are mess up.
I actually have 2 sets of SD cards with debian on them but now when I try to boot of debian I get this:

MMC rescan: current device # 0 initialized OK
2875692 bytes read in 1597 ms (1.7 MiB/s)
6535284 bytes read in 2175 ms (2.9 MiB/s)
## Booting kernel from Legacy Image at 00800000 ...
   Image Name:   Linux-3.18.5-kirkwood-tld-1
   Created:      2015-11-11   5:03:31 UTC
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    2875628 Bytes = 2.7 MiB
   Load Address: 00008000
   Entry Point:  00008000
   Verifying Checksum ... OK
## Loading init Ramdisk from Legacy Image at 01100000 ...
   Image Name:   initramfs-3.18.5-kirkwood-tld-1
   Created:      2015-02-19   1:49:36 UTC
   Image Type:   ARM Linux RAMDisk Image (gzip compressed)
   Data Size:    6535220 Bytes = 6.2 MiB
   Load Address: 00000000
   Entry Point:  00000000
   Verifying Checksum ... OK
   Loading Kernel Image ... OK
Using machid 0xf78 from environment

Starting kernel ...

Uncompressing Linux... done, booting the kernel

and it dies...
yet if I boot lede initramfs off usb it boots fine, I also tried debian on usb and it does the same thing, just hangs

Ok new developments, after trying so many things I can't even tell what actually fixed it, It is booting debian now and of course I'll be able to reinstall openwrt back to nand.
All I know is that it had to do with envs
I guess I'm gonna have to learn more about this if I want to continue tinkering with pogo in the future.
Thanks to everyone who help me...
You'all have a very happy 2018