Upgrade killed my router?

Hi all,

I use a LinkSys EA4500 router sind OpenWrt 16.x and yesterday in the evening I wanted to upgrade to version 18.06.4. As LUCI intended on the overview page, my router is E4200v2, I downloaded the bin file for this device here: https://openwrt.org/toh/linksys/ea4500

Then I uploaded it via LUCI and started the upgrade. The checkbox "Kepp existing config" (or something like that) was checked. The upgrade started and I saw I white page saying, that the upgrade is running and I shall wait some minutes, before reconnecting.

So I did, but even after 20 minutes, wifi could not be found and LAN connection didn't work, eather. Ok, I went to bed and hopped, that the upgrade is finished, until I wake up again. 7 hours later, wifi still wasn't available and I restarted the router and the modem (I use cable and "must" use my providers cable modem :().

No clue, what I can do further. The "LinkSys"-LED is glowing / on, but no wifi available. Do you have any ideas what I can try/do? I backuped my settings before upgrade, but this won't fix my problem?!

Thanks and kind regards,

Dirk

'Keep existing settings' may be to blame if you were upgrading from a much earlier release of OpenWrt.

Have you tried factory reset to see if it will remove incompatible Openwrt settings?
https://openwrt.org/docs/guide-user/troubleshooting/failsafe_and_factory_reset

eg. Leave router running for 1-2 minutes to make sure openwrt has started. Procedure is probably the same for your router. Press and hold Reset button down for 10 seconds. Release the button as soon as the LED light changes from 10 seconds. All settings should be erased. Connect to ethernet and log into 192.168.1.1. Wifi is normally disabled by default.

Someone else may be able to offer extra advice.

Did you use the sysupgrade version of file?
Did you verify the downloaded file integrity with sha256sum?
Finally did you take into consideration this ?

Hi bill888 and trendy,

thanks for your fast reponses.

@bill888: No, I didn't make a factory reset, yet. If nobody has another solution, I'll try this, thanks.
@trendy: Yes, I used this link:http://downloads.openwrt.org/releases/18.06.4/targets/kirkwood/generic/openwrt-18.06.4-kirkwood-linksys_viper-squashfs-sysupgrade.bin
As far as I got it on the download page in the "OpenWrt bootlog" section, it looked to me, OpenWrt checks this on its own and I didn't find a checksum on the page I downloaded the bin, from.
Yes, I think I took the notes into account. On the one hand I use it for longer time, now and on the other hand, so the wireless connection at all works for me fine,... but also booting the router should not have been a problem and also running it for a long time, it didn't get really warm. To me it seems, the router bootet "normal" but probably with a broken firmware.

Thanks and kind regards,

Dirk

Sorry, one more thing: If keeping the settings didn't work, is it possible that the whole router config is reset to the original config? I used ip like 10.50.50.1 before for the router. So it could be reset to 192.168.1.1 and wifi disbaled, because this is the "out of the box" pre-configuration?

fwiw, anything is possible....

It would be easy for you to check if there is any reply from router if it is at 192.168.1.1 before you consider factory resetting the router.

Hi bill888,

thanks for your response.

Since I'm at home from work I could find out some more: I was able to connect to the router via LAN over my 10.50.50.1 ip. Also internet was working via LAN.

To me it looks, only my wifi does not work. When I access "Wireless" in luci, I see the following in the "Wireless Overview":

Wireless Overview
Generic 802.11 Wireless Controller
Channel: ? (? GHz) | Bitrate: ? Mbit/s
-> below my configured wifis

When I then click "Add" on the right of the Generic 802.11 Wireless Controller, the next mask shows me "Wireless is not associated".

In the System Log I see the following errors:

[...]
Mon Aug 12 22:27:21 2019 kern.err kernel: [    0.008868] [Firmware Info]: /ocp@f1000000/ethernet-controller@72000/ethernet0-port@0: local-mac-address is not set
Mon Aug 12 22:27:21 2019 kern.err kernel: [    0.008966] [Firmware Info]: /ocp@f1000000/ethernet-controller@76000/ethernet1-port@0: local-mac-address is not set
[...]
Mon Aug 12 22:27:21 2019 kern.err kernel: [    0.802157] mtd: bad character after partition (f)
[...]
Mon Aug 12 22:27:21 2019 kern.err kernel: [    8.457606] ieee80211 phy0: Command RF_ANTENNA error 0x2
Mon Aug 12 22:27:21 2019 kern.warn kernel: [    8.462978] ieee80211 phy0: failed to set # of RX antennas
Mon Aug 12 22:27:21 2019 kern.err kernel: [    8.468517] ieee80211 phy0: Command RF_ANTENNA error 0x2
Mon Aug 12 22:27:21 2019 kern.warn kernel: [    8.473869] ieee80211 phy0: failed to set # of TX antennas
Mon Aug 12 22:27:21 2019 kern.info kernel: [    8.479388] ieee80211 phy0: 88w8366 v48, 586d8ff15017, STA firmware 4.1.0.3
Mon Aug 12 22:27:21 2019 kern.info kernel: [    8.489272] pci 0000:00:02.0: enabling device (0140 -> 0142)
Mon Aug 12 22:27:21 2019 kern.err kernel: [    9.297371] ieee80211 phy1: Command RF_ANTENNA error 0x2
Mon Aug 12 22:27:21 2019 kern.warn kernel: [    9.302742] ieee80211 phy1: failed to set # of RX antennas
Mon Aug 12 22:27:21 2019 kern.err kernel: [    9.308280] ieee80211 phy1: Command RF_ANTENNA error 0x2
Mon Aug 12 22:27:21 2019 kern.warn kernel: [    9.313630] ieee80211 phy1: failed to set # of TX antennas
Mon Aug 12 22:27:21 2019 kern.info kernel: [    9.319149] ieee80211 phy1: 88w8366 v48, 586d8ff15019, STA firmware 4.1.0.3
[...]
Mon Aug 12 22:27:24 2019 daemon.err uhttpd[2178]: bind(): Address not available
Mon Aug 12 22:27:24 2019 daemon.err uhttpd[2178]: Error: No sockets bound, unable to continue
[...]
Mon Aug 12 22:27:27 2019 daemon.err odhcp6c[2360]: Failed to send RS (Permission denied)
[...]
Mon Aug 12 22:27:28 2019 daemon.err odhcp6c[2360]: Failed to send DHCPV6 message to ff02::1:2 (Address not available)
[...]
Mon Aug 12 22:32:00 2019 daemon.err uhttpd[2509]: luci: accepted login on /admin/network/network for root from 10.50.50.10
Tue Aug 13 17:18:49 2019 cron.err crond[2142]: time disparity of 1126 minutes detected

The Kernel Log shows the following errors:

[...]
[    7.802256] pci 0000:00:01.0: enabling device (0140 -> 0142)
[    8.457606] ieee80211 phy0: Command RF_ANTENNA error 0x2
[    8.462978] ieee80211 phy0: failed to set # of RX antennas
[    8.468517] ieee80211 phy0: Command RF_ANTENNA error 0x2
[    8.473869] ieee80211 phy0: failed to set # of TX antennas
[    8.479388] ieee80211 phy0: 88w8366 v48, 586d8ff15017, STA firmware 4.1.0.3
[    8.489272] pci 0000:00:02.0: enabling device (0140 -> 0142)
[    9.297371] ieee80211 phy1: Command RF_ANTENNA error 0x2
[    9.302742] ieee80211 phy1: failed to set # of RX antennas
[    9.308280] ieee80211 phy1: Command RF_ANTENNA error 0x2
[    9.313630] ieee80211 phy1: failed to set # of TX antennas
[    9.319149] ieee80211 phy1: 88w8366 v48, 586d8ff15019, STA firmware 4.1.0.3
[...]

I tried to find some information to this "local-mac-address is not set" error, but couldn't find anything on google. Could this be the problem or can I post anything else where you can help me to solve the problem?

Thanks and kind regards,

Dirk

http://downloads.openwrt.org/releases/18.06.4/targets/kirkwood/generic/
Here you can see the sha256sum of each image. You can calculate it yourself before uploading the file to the router, otherwise if you upgrade in Luci it will be calculated by the router at the final step before it starts flashing the new image.

2 Likes

I think it would be better now to kill this thread and open a new one describing the "wifi doesn't work" problem.

restore your device to defaults and reconfigure from scratch. you can't expect configs to be compatible accross different releases, especially not with some borked marvell drivers

1 Like

Hi,

thanks for your responses.

I think I follow psyborg's hint and start from scratch.

Is this a general prroblem between releases or only because I jumped from version 16 to 18?

Thanks and kind regards,

Dirk

I guess you mean version 15.05. It's a lot different from 18.06.

You could try removing /etc/config/wireless then reboot to let it rebuild just that one file.

But overall it would be best to do a complete reinstall (sysupgrade -n) and be sure to check the sha256 of the file before flashing.

2 Likes

Good morning,

thanks for your response.
Before I read your response, I already made a "Restore defaults" from LUCI's "Firmware & Backup" mask.
After that, my router was accessible via 192.168.1.1, wi-fi disabled,... So I enabled wi-fi and recreated an initial one which worked.

But I now have another problem regarding ipv6 addresses. But therefore I'll open another issue, so there's a clear cut between my "upgrade problem" and the config problem.

Thanks to all of you and kind regards,

Dirk

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.