Upgrade/install Cisco/Linksys E2000 to later version of OpenWrt?

I was given a Cisco E2000 rooter which has OpenWrt Barrier Breaker 14.07 installed.
I am looking for a way to upgrade it to a later version. Upgrading via the web interface fails, probably because there are no sysupgrade, just install images available.
I then tried a fresh install using the tftp method. I was able to transfer an image using a tftp client connected to The image completely transferred (sucess message from tftp client with correct number of bytes transferred and confirmed with Wireshark), but then nothing changes, even if the router is left untouched for many minutes afterwards. Power cycling or even a 30/30/30 reset just brings up the installed 14.07 version.
For some reason no system upgrade seems to be performed.
I tried openwrt-19.07.7-brcm47xx-mips74k-linksys-e2000-v1-squashfs.bin as well as openwrt-15.05-brcm47xx-mips74k-linksys-e2000-v1-squashfs.bin; both of them seem to be discarded/ignored by the bootloader. I tried the same with FW_E2000_1.0.06.001_US_20140310_code.bin from Cisco, with the same result.
I am wondering what's a working way to upgrade or reinstall that router?

Have you tried renaming the firmware image to something shorter, e.g. openwrt-e2000_v1-squashfs.bin?

yes, I tried that - in vain; e.g. openwrt-15.05.bin or openwrt-19.07.7-squashfs.bin

If you already have (an old version of-) OpenWrt installed, sysupgrade should work. However be aware that this device has two issues, very little RAM (32 MB) and BCM4322 802.11n wireless (which is only partially supported by b43, limited to 802.11g/ 54 MBit/s at most) - either of them spoil the fun with this device.

If you can avoid bootloader based flashing (without a serial console attached), you should do that, as Linksys liked to break it (capping the maximum upload size to a too small value).

Disclaimer: I own the roughly comparable wrt610n v1 - and haven't actually used it in decade, as its wireless side simply isn't worth it.

Yes, I am aware of the difficulties about 802.11n on that device. For example, the currently installed 14.07 does not seem to support it.
When I choose Flash New Firmware Image with any of the firmware selected, I always get
"The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform."
Unlike for other platforms, there is no upgrade image to download for the E2000. Is there an image that's known to work as an upgrade via the 14.07 OpenWRT web interface?

save the image in /tmp (transfered via scp). then try via ssh
sysupgrade -n /tmp/openwrt-19.07.7-brcm47xx-mips74k-linksys-e2000-v1-squashfs.bin

This is what I get (I had renamed the file to have a shorter filename):

root@OpenWrt:/# sysupgrade -n /tmp/openwrt-19.07.7-squashfs.bin

Invalid image type. Please use only .trx files

Image check 'platform_check_image' failed.

The reason is probably that it's an install, not a sysupgrade file.
It looks like there are no sysupgrade file for the e2000 though.

This thread is talking about renaming the .bin to .trx. On the other hand there are indications that the trx file is a .bin with the first 32 bytes removed. Can anyone maybe elaborate on that? Would it apply to OpenWRT images as well?

I came across this thread from last year:

Also I found this


referenced from https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=626331

It says one needs to "break" the installed system for the tfto upload to be accepted. Is that correct?

ok then let's force it
sysupgrade -n -F /tmp/openwrt-19.07.7-squashfs.bin

-F | --force
                     Flash image even if image checks fail, this is dangerous!

OK, this is how it finally worked:

tail -c +33 openwrt-19.07.7-squashfs.bin > openwrt-19.07.7-squashfs.trx

and then I could successfully upload that trx file through the OpenWRT 14.07 web interface. Maybe this was only an issue in 14.07?
The box is running OpenWRT 19.07 now. It provides a Generic 802.11bg interface which seems to work (at least I can see the other WiFis; no further tests done). The next challenge will be to get 802.11n support running.

1 Like

sysupgrade should support both *.bin and *.trx images transparently - while I knew that some older versions didn't properly support *.bin (I've fallen into that trap on my wrt610nv1 as well), I didn't expect barrier breaker to be affected as well.

That's the problem with those ancient versions, no one remembers anymore.