Updating to 18.06.2 bricked my device

Hello all,

I have a TP-Link Archer C7 v4 and was using OpenWrt 18.06.1. I saw the new version, 18.06.2 and downloaded the SYSUPDATE bin. Used the firmware upgrade option in LuCi, the image was accepted and started upgrading. As expected, I lost SSID broadcast.

After 10 minutes, it did not come up.

I powered off and on. After botting, the SSIDs came back, but I could not access LuCi, it would just try to connect with no response.

I did a reset (held the reset button with a staple for over 10 seconds).

Now, I don't even get SSID anymore.
The led for wireless are not on. Only power and ethernet are on.

I read that there seems to be an issue when upgrading via LuCi, is that right? In this case why it was not disabled, to avoid bricking the device like that...

Any idea on what to do now?

Thank you!

  • Are you sure that you upgraded to 18.06.2?

This description seems like you installed a Snapshot firmware (with no LuCI web GUI).

Then it seems like you reset the device to defaults.

  • Can you try to SSH to the router instead?

Yes, I didn't even download the Snapshot. First I tried with Factory, then it rejected. Then I correctly downloaded Sysupgrade.
I don't understand why it never came back correctly after waiting 10 minutes for the firmware to update. I had to power off and on. But then I could not load LuCi anymore, and I confirmed the IP of the router is correct.

Yes, I reset. However it should still broadcast the default SSIDs, correct?

I have to try SSH later when I'm at home. I'm just trying to save time and gather as much info as possible because I need Internet up again tonight. Would you mind sharing some advice of what to try?

Snapshots have factory and sysupgrade images too, so your statement didn't actually clarify that.

Incorrect. It shouldn't have done that. If you reset to defaults, the WiFi should be disabled by default.

I hope this helps.

I'm not certain on what else to share. I'd personally verify that I'm receiving an IPv4 address via DHCP.

Also, I'd advise you not to reboot a router during sysupgrade.

1 Like

Thanks, I thought it would be enabled by default. I'll try via ethernet to see if an IP is assigned and I can access LuCi.

Yes, I'm fully aware. However 10 minutes passed and router did not come up, so it was the only option. Something might not be right when updating via LuCi.

Thanks for helping!

1 Like

Fortunately the reset worked - yes, by default the wireless (SSIDs) are disabled, that's why I was not seeing them.
The upgrade ended up applying, but it really got stuck after upgrading (router was not operational even after 10 minutes after applying the new firmware), I could only "recover" the router doing a reset.


If your case is solved, please mark it as such.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.