Updating dropbear on older installation

Hello!

I have a small router (mr3020) with an older openWRT installation (chaos calmer) and I would like to update dropbear, as I have problems with it. The currently installed version is about 2 years old I think, so it's about time :slight_smile:

As far as I can see I cannot use opkg for that because there is no updated package available. Is there an easy way to get a new version of dropbear on this device? Perhaps there is a compatible package for another device or something like that. I basically just need a recent binary of dropbear that is compatible with the architecture I think.

Can anyone point me in the right direction?

17.01.5 should run on that unit. That gets you several other security improvements.

I'm not sure when the libraries were changed. If the same C library is in use, often you can use the binary from a user-space program across different versions.

1 Like

Thanks for the response.

So I guess you mean that I can take a package from here:
https://downloads.openwrt.org/releases/17.01.5/packages/

Do you know which subfolder I need to use? I thought I need ar71xx, but that does not exist there.

No.
17.01 packages (using musl C library) are incompatible with the ancient 15.05 (using uClibc)

1 Like

ok, so the packages here at openwrt seem to be no option. Is there any other source for binary packagas that I can use?

If not, is it possible to compile it myself? If yes, is it a straightforward process or rather tricky?

You should be able to, since there's source code.

Should be straightforward if you follow the OpenWrt Wiki: https://openwrt.org/docs/guide-developer/start

Yes, moving to a current release (18.06.x) would be suggested. (Version corrected, thanks to the following comment!)

https://openwrt.org/downloads

1 Like

@jeff 18.06 :wink:

If you're going to try to run an old buildroot (not recommended), install a version of Linux from about the same era on your build machine. This helps a lot of things but there will still be problems.

You can select uClibc in a new build but it may not be the same library that is on the old OS.

That wasn't a very helpful advice, since as far as I can see my hardware is not supported by 18.06.x.

Compiling the package was indeed straitforward, so this was the best way. The new package installed with opkg without problems. Thanks everyone for the help!

@theBoatman If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)

You can also mark the reply that solved your problem:
grafik

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.