Updating device software/ upgrading

Hello all,

I have a quick kinda like a question and comment.

I have latest version openwrt

|Model|Linksys E4200 v2 (Viper)|
|Architecture|Feroceon 88FR131 rev 1 (v5l)|
|Target Platform|kirkwood/generic|
|Firmware Version|OpenWrt 22.03.0 r19685-512e76967f / LuCI openwrt-22.03 branch git-22.245.77528-487e58a|
|Kernel Version|5.10.138|

after installing it, whenever I try to update/upgrade installed software I get a bunch of errors>

I tried to find solutions but alot having similar questions but not real answer is helping,

after trying for many days,
even though the packages can be downloaded manually without issues the Luci ui give me alot of error messages that it couldnt download,

then after manually uploading to the ui i get issues it say cannot install.

then randomly I went in the packages list and had an idea to change the protocol from https to http, out of no where everything worked soooo well, I am not sure why. I am guessed ssl library had some missing updates but not matter what I do, nothing fixed the issue, updated alot of packages that has ssl with no luck.

overall it seemed to be fixed with HTTP stand alone, if anyone having issues this can be a one solution, temproraly until we figure out what causing the https to fail.



In general, never run opkg upgrade. Use attendedsysupgrade instead. The attended sysupgrade will make and install a complete new ROM with everything matching.

Please post the detailed errors you are getting.